POJ 1328 Radar Installation

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 58677 Accepted: 13205
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output

Case 1: 2

Case 2: 1


贪心的升级版,将点的坐标转化为在坐标轴上的区间,然后计数在坐标轴上的区间有几段重合的,重合的段数就是雷达安装的个数。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <math.h>
#include <stdlib.h>
using namespace std;
struct late
{
    double x,y,xx,yy;
}late[1005],ll[1005];

bool cmp(struct late a,struct late b)
{
    if(a.xx!=b.xx) return a.xx<b.xx;
    return a.yy<b.yy;
}
int main(void)
{
    //freopen("T.txt","r",stdin);
    int n;
     int l=1;
    double d;
    while(scanf("%d%lf",&n,&d),(n||d))
    {
        int ok=1;
        for(int i=1;i<=n;i++)
        {
            scanf("%lf%lf",&late[i].x,&late[i].y);
            late[i].xx=late[i].x-sqrt(d*d-late[i].y*late[i].y);
            late[i].yy=late[i].x+sqrt(d*d-late[i].y*late[i].y);
            if(fabs(late[i].y)>d) ok=0;
          //  printf("xx %lf yy %lf\n",late[i].xx,late[i].yy);
        }
        if(ok==0)
		printf("Case %d: -1\n",l++);
        else
        {
              sort(late+1,late+n+1,cmp);
              for(int i=1;i<=n;i++)
            //  printf("xx %lf yy %lf\n",late[i].xx,late[i].yy);
              ll[1].xx=late[1].xx;
              ll[1].yy=late[1].yy;
              int k=1;
              for(int i=2;i<=n;i++)
              {
                  int ok=0;
                  for(int j=1;j<=k;j++)
                  {
              //    	printf(" ll.xx  %lf ll.yy  %lf late.xx%lf  late.yy%lf\n",ll[j].xx,ll[j].yy,late[i].xx,late[i].yy);
                      if(late[i].xx>=ll[j].xx&&late[i].xx<=ll[j].yy)
                      {//printf("fgdfg\n");
                          ok=1;
                          ll[j].xx=late[i].xx;
                          if(late[i].yy<ll[j].yy)
                            ll[j].yy=late[i].yy;
                          break;
                      }
                  }
                  if(ok==0)
                  {
                      ll[++k].xx=late[i].xx;
                      ll[k].yy=late[i].yy;
                  }
              }
              printf("Case %d: ",l++);
              printf("%d\n",k);
        }


    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值