POJ 2393 Yogurt factory

Yogurt factory
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7306 Accepted: 3743
Description

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week.

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt.

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.
Input

* Line 1: Two space-separated integers, N and S.

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.
Output

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.
Sample Input

4 5
88 200
89 400
97 300
91 500
Sample Output

126900
Hint

OUTPUT DETAILS:

In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units.

这个做法没错误!暴力找出最小的花费情况,但是没有考虑到时间会超出,这道题原来想的是套用贪心常用的模板,可是居然遇到了贪心常见算法的升级版!开始的时候以为这道题和以前那些题的区别只是不用结构体排序了,每一个的花费总量数据和之前的每一个数据相比,只取最小的那一个,结果却是超时,数据量太大了。所以就有了下面的优化。。。。。



超时代码:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int maxn=10011;
int n,s;
struct week
{
    __int64 c;
    __int64 y;
}week[10005];
int main()
{
   // freopen("S.txt","r",stdin);
    while(scanf("%d%d",&n,&s)!=EOF)
    {
	for(int i=1;i<=n;i++)
	    scanf("%I64d%I64d",&week[i].c,&week[i].y);
	__int64 sum=0;
	sum+=week[1].c*week[1].y;
    for(int i=2;i<=n;i++)
    {
        __int64 min=week[i].c*week[i].y;
        for(int j=1;j<i;j++)
        {
            __int64 money=week[i].y*week[j].c+(i-j)*s*week[i].y;
            min=(min<money)?min:money;
        }
        sum+=min;
    }
	printf("%I64d\n",sum);
    }
    return 0;
}



将n的平方优化为 n的效率,将每一周的最小花费都更新,使得每一周的花费都是最小值,而这个最小值就用一个循环将每个周的花费及时更新,看看到底是存几个周核算,还是直接本周生产的单价少。最后再计算花费最小的总量。

#include <iostream>
#include <cstdio>
#include <math.h>
#include <algorithm>
using namespace std;
struct week
{
    __int64 c,y;
}week[10005];
int main(void)
{
  //freopen("S.txt","r",stdin);
    int n,s;
    scanf("%d%d",&n,&s);
        for(int i=1;i<=n;i++)
     scanf("%I64d%I64d",&week[i].c,&week[i].y);
    __int64 sum=0;
    for(int i=2;i<=n;i++)
    week[i].c=min(week[i-1].c+s,week[i].c);
    for(int i=1;i<=n;i++)
        sum+=week[i].c*week[i].y;
   printf("%I64d\n",sum);

   // printf("%d\n",88*200+89*700+300*5+500*91);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值