POJ 1323 Game Prediction

Game Prediction
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9870 Accepted: 4733
Description

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game.



Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.
Input

The input consists of several test cases. The first line of each case contains two integers m (2?20) and n (1?50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases.

The input is terminated by a line with two zeros.
Output

For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.

Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0
Sample Output

Case 1: 2

Case 2: 4

我的英语水平这么差么?大哭,读了好久都没读懂,贪心算法的题读不懂看数据也很难模拟对,通常情况下,题看懂了,基本就可以解决了,思路一时半会没有,10分钟之后就有了,所以,时刻提醒自己,不要着急,虽然在这一分钟没有思路,说不定在下一分钟思路就出来了呢,这种情况必须出现在脑子清醒的状态下。


模板 !模板! m个人每人发n张牌,共有m*n张牌,大小从1排到m*n,给出自己一共有的那几张牌的数,按照平常日子打牌的规律,问自己能剩的有几轮?

肯定是将自己的牌从大往小开始发出去啦,当然实际生活中不能这么干,实际生活中要是赢得轮次多的话,那就不靠脑子了,靠运气啦。。。如果自己手中最大的发出去,“外边”有没有再大的牌压住自己,那么自己就赢了,你懂得,如果有比自己大的牌,就输了,但是对手的这张令自己失败的牌也收不回去了,就标记为已经发出去的牌,自己的这张也得标记为发出去的牌了。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <memory.h>
using namespace std;

int a[1005],b[1005];
bool cmp(int a,int b)
{
    return a>b;
}
int main(void)
{
   // freopen("S.txt","r",stdin);
    int m,n;
    int l=1;
    while(scanf("%d%d",&m,&n),(m||n))
    {
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++)
           {
                scanf("%d",&b[i]);
                a[b[i]]=1;
           }
           sort(b+1,b+n+1,cmp);
           int sum=0;
           for(int i=1;i<=n;i++)
           {
               int ok=1;
               for(int j=n*m;j>b[i];j--)
               {
                   if(a[j]==0)
                   {
                       ok=0;
                       a[j]=1;
                       break;
                   }
               }
               if(ok==1)
                sum++;
           }
           printf("Case %d: %d\n",l++,sum);
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值