POJ 3069 Saruman's Army

该问题描述了一种策略,通过放置增血石(类似Palantirs)来覆盖所有军队位置,使得每个位置都在至少一块石头的影响范围内。案例中提到,在第二测试用例中,可以在位置7、20、50和70放置石头,以覆盖所有军队。算法思路是首先对位置进行排序,然后从最左侧开始,找到距离当前点r范围内的最右侧未覆盖点放置石头,重复此过程直到所有点都被覆盖。
摘要由CSDN通过智能技术生成
Saruman's Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5071 Accepted: 2628
Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1
Sample Output

2
4
Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.


我理解的是增血石能能加周围一定距离之内的所有人的血,给了每个人的位置,求设置几个增血的石头可以让所有人都在回血,且石头数量最少。网上有的说是灯,都差不多。

首先排序,从最左边的开始,设为cur点,找到离这个点r距离的点的最近的左边的那一个点设置一个石头,这样左边的点都能覆盖掉,然后设置石头的这个点右边距离r以内的点也都能覆盖掉,然后找到第一个没被覆盖的点,作为新的cur点,再按照上述步骤重新来,一直到cur点大于最右端的点,结束;


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[2005];
int main(void)
{
   // freopen("B.txt","r",stdin);
    int r,n;
    while(scanf("%d%d",&r,&n)!=EOF)
    {
        if(r==-1&&n==-1)
            break;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        sort(a+1,a+n+1);
        int cur=1;
        int count=0;
        while(cur<=n)
        {
            int i;
            for(i=1;i<=n;i++)
                if(a[i]>a[cur]+r)
                break;
            int j;
            for(j=i;j<=n;j++)
                if(a[j]>a[i-1]+r)
                break;
            cur=j;
            count++;
        }
        printf("%d\n",count);
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值