POJ 1007 DNA Sorting

DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 80676 Accepted: 32471

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
代码:

<span style="font-size:14px;">import java.util.Arrays;
import java.util.Scanner;

public class P1007_DNASorting {
	private static class DNA implements Comparable{
		private int inversionnum;
		private  String dnasq;
		@Override
		public int compareTo(Object o) {
				DNA dna=(DNA)o;
				if(this.inversionnum>dna.inversionnum)
					return 1;
				else if(this.inversionnum<dna.inversionnum)
					return -1;
				else return 0;
		}
	}
	
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int len=in.nextInt();
		int T=in.nextInt();
		DNA[] dna=new DNA[T];
		int[] n= new int[4];
		for(int i=0;i<T;i++){
			dna[i]=new DNA();
			dna[i].dnasq=in.next();
			dna[i].inversionnum=inversionNumber(dna[i].dnasq,len);
		}
		Arrays.sort(dna);
		for(int i=0;i<T;i++){
			System.out.println(dna[i].dnasq);
		}
	}
	public static int inversionNumber(String s,int len){
		int ans=0;
		int A,C,G;
		A=C=G=0;
		for(int i=len-1;i>=0;i--){
			switch(s.charAt(i)){
				case 'A':{
					A++;
					break;
				}
				case 'C':{
					C++;
					ans+=A;
					break;
				}
				case 'G':{
					G++;
					ans+=A+C;
					break;
				}
				case 'T':{
					ans+=A+C+G;
					break;
				}
			}
		}
		return ans;
	}
}</span>








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值