POJ - 1007 -- DNA Sorting【排序+逆序对】

DNA Sorting
Description

One measure of “unsortedness’’ in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ”DAABEC’’, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ”AACEDGG’’ has only one inversion (E and D)—it is nearly sorted—while the sequence ``ZWQM’’ has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of “sortedness’’, from ”most sorted’’ to ``least sorted’’. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from “most sorted’’ to ``least sorted’’. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

题意

给你m个DNA序列,每个DNA序列长为n的字符串,问讲这些DNA序列按照逆序对数从小到大排序。

思路

用pair做映射关系,将DNA序列和其逆序对数存到pair中,逆序对是键,DNA序列是值,然后求每个DNA的逆序对数,可以用1代替A,2代替B…
pair自带优先级,以键为第一个优先,值为第二个优先,都是从小到大排列的。

AC代码
#include<iostream>
#include<string>
#include<vector>
#include<utility>
#include<algorithm>
using namespace std;
typedef long long ll;
typedef pair<ll,string> pll;
const int maxn=100+5;
int arr[maxn],temp[maxn];
int k=0;
void merger(int l1, int r1, int l2, int r2){
	int i=l1,j=l2;
	int cnt=0;
	while(i<=r1 && j<=r2){
		if(arr[i]<=arr[j])	temp[cnt++] = arr[i++];
		else{
			temp[cnt++] = arr[j++];
			k+=r1-i+1;
		}
	}
	while(i<=r1)	temp[cnt++] = arr[i++];
	while(j<=r2)	temp[cnt++] = arr[j++];
	for(i=0;i<cnt;i++)	arr[l1+i] = temp[i];
}
void mergerSort(int l, int r){
	if(r>l){
		int mid=(l+r)>>1;
		mergerSort(l,mid);
		mergerSort(mid+1,r);
		merger(l,mid,mid+1,r);
	}
}
int main(){
	int n,m;
	string s;
	vector<pll> v;
	cin>>n>>m;
	for(int i=0;i<m;i++){
		k=0;
		cin>>s;
		for(int j=0;j<n;j++)
			arr[i]=s[i]-'A';
		mergerSort(0,n-1);
		v.push_back(pll(k,s));
	}
	sort(v.begin(),v.end());
	for(int i=0;i<m;i++)
		cout<<v[i].second<<endl;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

星空皓月

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值