复数类--重载运算符+

Problem A: C++习题 复数类--重载运算符+

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 438   Solved: 285
[ Submit][ Status][ Web Board]

Description

定义一个复数类Complex,重载运算符“+”,使之能用于复数的加法运算。将运算符函数重载为非成员、非友元的普通函数。编写程序,求两个复数之和。

Input

两个复数

Output

复数之和

Sample Input

3 4
5 -10

Sample Output

(8.00,-6.00i)

HINT

前置代码及类型定义已给定如下,提交时不需要包含,会自动添加到程序前部



/* C++代码 */

#include <iostream>

#include <iomanip>

using namespace std;

class Complex

{

public:

    Complex();

    Complex(double r,double i);

    double get_real();

    double get_imag();

    void display();

private:

    double real;

    double imag;

};





主函数已给定如下,提交时不需要包含,会自动添加到程序尾部



/* C++代码 */



int main()

{

    double real,imag;

    cin>>real>>imag;

    Complex c1(real,imag);

    cin>>real>>imag;

    Complex c2(real,imag);

    Complex c3=c1+c2;

    cout<<setiosflags(ios::fixed);

    cout<<setprecision(2);

    c3.display();

    return 0;

}

#include <iostream>

#include <iomanip>

using namespace std;

class Complex

{

public:

    Complex();

    Complex(double r,double i);

    double get_real();

    double get_imag();

    void display();

private:

    double real;

    double imag;

};

Complex::Complex(double r,double i):real(r),imag(i){}

double Complex::get_real(){return real;}

double Complex::get_imag(){return imag;}

Complex operator + (Complex &a,Complex &b)
{
    return Complex(a.get_real() + b.get_real(),a.get_imag()+ b.get_imag());
}
void Complex::display()
{
    cout<<'('<<real<<','<<imag<<"i)"<<endl;
}
int main()

{

    double real,imag;

    cin>>real>>imag;

    Complex c1(real,imag);

    cin>>real>>imag;

    Complex c2(real,imag);

    Complex c3=c1+c2;

    cout<<setiosflags(ios::fixed);

    cout<<setprecision(2);

    c3.display();

    return 0;

}


 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

IT研究僧大师兄

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值