C - Fractal(3.4.1)

Description

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales.
A box fractal is defined as below :
  • A box fractal of degree 1 is simply
    X
  • A box fractal of degree 2 is
    X X
    X
    X X
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following
    B(n - 1)        B(n - 1)
    
            B(n - 1)
    
    B(n - 1)        B(n - 1)

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-

//递归方法
#include <iostream>
#include <string>
#include <cstring>
#include <cmath>
using namespace std;

#define M 1000
char s[M][M];

void print( int n, int x, int y)
{
    int m;//m 表示方盒子规模 即边长
    if( n == 1 )
    {
        s[x][y] = 'X';   //回溯,当n=1时,为(x,y)坐标赋值'X'
        return ;
    }
    else if( n > 1 )
    {
        m = pow( 3, n - 2 );  //计算盒子规模
        print( n - 1, x, y );   //左上角第一个图形进行递归打印,第一个图形左上角坐标为(x,y)
        print( n - 1, x, y + 2 * m ); //右上角第二个图形进行递归打印,第二个图形左上角坐标为(x,y+2*m)
        print( n - 1, x + m, y + m );  //中间第三个图形进行递归打印,第三个图形左上角坐标为(x+m,y+m)
        print( n - 1, x + 2 * m, y );  //左下角第四个图形进行递归打印,第四个图形左下角坐标为(x+2*m,y)
        print( n - 1, x + 2 * m, y + 2 * m);//右下角第五个图形进行递归打印,第五个图形右下角坐标为(x+2*m,y+2*m)
    }
}

int main()
{
    int n, i, p;
    while(cin >> n && n != -1 )
    {
        p = pow( 3, n - 1 );  //计算方盒子规模
        for( i = 0; i < p; i++ )   //对数组进行初始化
        {
            memset( s + i, ' ', p );   //每一行均初始化为空格
            s[i][p] = '\n';     //每一行最后一列初始化为\0,如果不这样做,会出错,图形无法输出
        }
        print( n, 0, 0 );   //从左上角(x,y)坐标开始打印
        for( i = 0; i < p; i++)
            cout << s[i] ;     //输出图形
        cout << '-' << endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

IT研究僧大师兄

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值