hdu 4708 Rotation Lock Puzzle

34 篇文章 6 订阅

Rotation Lock Puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1836    Accepted Submission(s): 580


Problem Description
Alice was felling into a cave. She found a strange door with a number square matrix. These numbers can be rotated around the center clockwise or counterclockwise. A fairy came and told her how to solve this puzzle lock: “When the sum of main diagonal and anti-diagonal is maximum, the door is open.”.
Here, main diagonal is the diagonal runs from the top left corner to the bottom right corner, and anti-diagonal runs from the top right to the bottom left corner. The size of square matrix is always odd.


This sample is a square matrix with 5*5. The numbers with vertical shadow can be rotated around center ‘3’, the numbers with horizontal shadow is another queue. Alice found that if she rotated vertical shadow number with one step, the sum of two diagonals is maximum value of 72 (the center number is counted only once).

Input
Multi cases is included in the input file. The first line of each case is the size of matrix n, n is a odd number and 3<=n<=9.There are n lines followed, each line contain n integers. It is end of input when n is 0 .
 
Output
For each test case, output the maximum sum of two diagonals and minimum steps to reach this target in one line.

Sample Input
  
  
5 9 3 2 5 9 7 4 7 5 4 6 9 3 9 3 5 2 8 7 2 9 9 4 1 9 0
 
Sample Output
  
  
72 1
 
Source
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;

int ma[16][16];
int sum[10][10];//从中间起第i圈分为j个组,这j个组的和
int q[12]= {0,1,2,3,4,5,6,7,8,9,10,11}; //从中间向外扩

int main()
{
    int n;
    int i,j;
    int t;
    int k;
    int ma_sum,ma_loc;
    int tol_sum;
    int tol_step;

    while(~scanf("%d",&n))
    {
        if(n==0)
        {
            break;
        }

        for(i=0; i<n; ++i)
        {
            for(j=0; j<n; ++j)
            {
                scanf("%d",&ma[i][j]);
            }
        }

        t=n/2;
        memset(sum,0,sizeof(sum));
        tol_sum=0;
        tol_step=0;
        for(i=0; i<t; ++i)
        {
            ma_sum=0;
            for(j=0; j<(i+1)*2; ++j)
            {
                sum[i][j]=ma[t-i-1+q[j]][t-i-1]+ma[t+i+1][t-i-1+q[j]]+ma[t+i+1-q[j]][t+i+1]+ma[t-i-1][t+i+1-q[j]];
                //  cout<<ma[t-i-1+q[j]][t-i-1]<<" "<<ma[t+i+1][t-i-1+q[j]]<<" "<<ma[t+i+1-q[j]][t+i+1]<<" "<<ma[t-i-1][t+i+1-q[j]]<<endl;
                if(sum[i][j]>ma_sum)
                {
                    ma_sum=sum[i][j];
                    ma_loc=j;
                }
            }
            if(ma_loc-0<(i+1)*2-ma_loc)
            {
                tol_step+=ma_loc;
            }
            else
            {
                tol_step+=(i+1)*2-ma_loc;
            }

            tol_sum+=ma_sum;
        }

        printf("%d %d\n",tol_sum+ma[t][t],tol_step);

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值