hdu 4763 Theme Section

9 篇文章 0 订阅

It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'. 

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us? 
Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song. 
Sample Input
5
xy
abc
aaa
aaaaba
aaxoaaaaa
Sample Output
0
0
1
1
2


题意概况:找出最长相同前后缀,且在这个字符串中除去前后缀的位置还有这个前后缀出现。

  解题思路:通过next找出所有位置的最大真前后缀,然后看这个前后缀的长度是否小于字符串整体长度的三分之一,如果大于调到下一个位置的找最大前后缀,如果符合则需要找出在这个字符串中除去前后缀的位置是否还有这个前后缀出现,如果没有出现跳到下一位置寻找最大前后缀继续判断是否符合各个条件。最后输出找到的最长前后缀长度。

  代码:
#include<stdio.h>
#include<string.h>
#define N 1010000
int next[N];
void GetNext(char s[])
{
	memset(next,0,sizeof(next));
	int l=strlen(s);
	int i=0;
	int j=-1;
	next[0]=-1;
	while(i<l)
	{
		if(j==-1||s[i]==s[j])
		{
			i++;
			j++;
			next[i]=j;
		}
		else
		{
			j=next[j];
		}
	}
	/*for(i=0;i<=l;i++)
	{
		printf("%d .",next[i]);
	}
	printf("\n");*/
}
void KMP(char s[])
{
	GetNext(s);
	int l=strlen(s);
	int i=l;
	if(next[i]==0)
		printf("0\n");
	else
	{
		while(i>0&&i<=l)
		{
			if(next[i]*3<=l)
			{
				int i1=next[i];
				int j1=0;
				int l1=l-next[i];
				int l2=next[i];
				while(i1<l1&&j1<l2)
				{
					if(j1==-1||s[i1]==s[j1])
					{
						i1++;
						j1++;
					}
					else
					{
						j1=next[j1];
					}
					
				}
				if(j1==l2)
				{
					printf("%d\n",next[i]);
					break;
				}	
				else
				{
					if(next[i]==0)
					break;
					i=next[i];
				}
					
			}
			if(next[i]*3>l)
			{
				if(next[i]==0)
				break;
				i=next[i];
			}
		}
	}
}
int main()
{
	char s[N];
	int t;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		gets(s);
		KMP(s);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值