A Simple Game
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/65535 K (Java/Others)Total Submission(s): 1062 Accepted Submission(s): 655
Problem Description
Agrael likes play a simple game with his friend Animal during the classes. In this Game there are n piles of stones numbered from 1 to n, the 1st pile has M
1 stones, the 2nd pile has M
2 stones, ... and the n-th pile contain M
n stones. Agrael and Animal take turns to move and in each move each of the players can take at most L
1 stones from the 1st pile or take at most L
2 stones from the 2nd pile or ... or take L
n stones from the n-th pile. The player who takes the last stone wins.
After Agrael and Animal have played the game for months, the teacher finally got angry and decided to punish them. But when he knows the rule of the game, he is so interested in this game that he asks Agrael to play the game with him and if Agrael wins, he won't be punished, can Agrael win the game if the teacher and Agrael both take the best move in their turn?
The teacher always moves first(-_-), and in each turn a player must takes at least 1 stones and they can't take stones from more than one piles.
After Agrael and Animal have played the game for months, the teacher finally got angry and decided to punish them. But when he knows the rule of the game, he is so interested in this game that he asks Agrael to play the game with him and if Agrael wins, he won't be punished, can Agrael win the game if the teacher and Agrael both take the best move in their turn?
The teacher always moves first(-_-), and in each turn a player must takes at least 1 stones and they can't take stones from more than one piles.
Input
The first line contains the number of test cases. Each test cases begin with the number n (n ≤ 10), represent there are n piles. Then there are n lines follows, the i-th line contains two numbers M
i and L
i (20 ≥ M
i > 0, 20 ≥ L
i > 0).
Output
Your program output one line per case, if Agrael can win the game print "Yes", else print "No".
Sample Input
2 1 5 4 2 1 1 2 2
Sample Output
Yes No
巴什博奕和尼姆博弈的综合。
令Bi=Mi mod(Li+1)
定义T‘=B1 xor B2 xor ... xor Bn
如果T‘=0 那么没有获胜可能,先取者必败
如果T’>0 那么必然存在取的方法,使得T‘=0,
#include<stdio.h>
#include <iostream>
using namespace std;
int main()
{
int t,sum,n,m,L;
cin>>t;
while (t--)
{
cin>>n;
sum=0;
for (int i=0; i<n; i++)
{
cin>>m>>L;
sum^=(m%(L+1));
}
if(sum==0)
{
cout<<"Yes"<<endl;
}
else
{
cout<<"No"<<endl;
}
}
return 0;
}