hdu 3177 Crixalis's Equipment

Crixalis's Equipment

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2680    Accepted Submission(s): 1104


Problem Description
Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.
 

Input
The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.
0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.
 

Output
For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".
 

Sample Input
  
  
2 20 3 10 20 3 10 1 7 10 2 1 10 2 11
 

Sample Output
  
  
Yes No

题意:要将一些物品搬进洞里面,这些物品搬运过程中的体积为bi,停下来的体积为ai,问这一部分物品能不能全部搬到洞里面去!

          停放体积         移动体积

            第一件物品          a1             b1

           第二件物品          a2             b2


假设这两件物品的移动体积都不大于洞的体积V 那么将单独比较两个物品的时候会发现  a1+b2为先放第一件物品 后放第二件物品的最大瞬时体积, a2+b1为先放第二件物品 后放第一件物品的最大瞬时体积,我们应该选择a1+b2和a2+b1中比较小的先放,那么从2件物品 扩展到N件物品 假设n件物品的移动体积都不大于洞的体积V(如果有大于的 那么结果必然是NO),将N件物品按照a1+b2<a2+b1进行排序 然后依次放入洞中。

#include<stdio.h>
#include <iostream>
using namespace std;
struct node
{
    int a;
    int b;
};
int cmp(const void *a,const void *b)
{
    node *d1=(node*)a;
    node *d2=(node*)b;
    return (d1->a+d2->b)-(d2->a+d1->b);
}
int main()
{
    int N,T,V,i;
    node d[10001];
    cin>>T;
    while (T--)
    {
        cin>>V>>N;
        for (i=0; i<N; i++)
        {
            cin>>d[i].a>>d[i].b;
        }
        qsort(d, N, sizeof(d[0]), cmp);
        for (i=0; i<N; i++)
        {
            if(V>=d[i].b)
            {
                V-=d[i].a;
            }
            else
            {
                cout<<"No"<<endl;
                break;
            }
        }
        if(i==N)
        {
            cout<<"Yes"<<endl;
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值