hdu 1789 Doing Homework again

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6440    Accepted Submission(s): 3828


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 


哎,自己太弱了,想得太肤浅了,根本想不到用个数组来标记,通过这个数组,如果访问过了,就是1,没有访问不过就是0,如果这一天已经使用过,那么就让它减,直到找到某一天没有访问过的某一天,如果均都访问过,则是要与ans相加.

#include<stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
struct node
{
    int day;
    int score;
};
int cmp(const void *a,const void *b)
{
    node *d1=(node*)a;
    node *d2=(node*)b;
    if(d2->score==d1->score)
    {
        return d1->day-d2->day;
    }
    else
    {
        return d2->score-d1->score;
    }
}
int flag[1001];   //用于标记的数组
int main()
{
    node d[10001];
    int n,N;
    int j,ans;
    cin>>N;
    while (N--)
    {
        ans=0;
        memset(flag, 0, sizeof(flag));
        cin>>n;
        for (int i=0; i<n; i++)
        {
            cin>>d[i].day;

        }
        for (int i=0; i<n; i++)
        {
            cin>>d[i].score;
        }
        qsort(d, n, sizeof(node), cmp);
        for (int i=0; i<n; i++)
        {
        
            for (j=d[i].day; j>0; j--)  //扫描少于该次天数的作业(少于当前限制天数的作业一定可以在该作业之前完成)
            {
                if(flag[j]==0) 
                {
                    flag[j]=1;   //记录
                    break;
                }
            }
            if(j==0)           //超时未完成
            {
                ans+=d[i].score;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值