Doing Homework again
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 15014 Accepted Submission(s): 8770
Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
Output
For each test case, you should output the smallest total reduced score, one line per test case.
Sample Input
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
Sample Output
0 3 5
Author
lcy
Source
思路:要让扣的分数最少,就先要将分数最大的作业先完成,但是如果有分数一样的作业,那么就要做最着急交的作业。所以应该将数据先按分数从大到小排,然后再按截止日期从小到大排。然后按照排好的顺序从最后一天开始查找是否有时间就行了。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
struct node
{
int dead,grade;
}q[1005];
bool cmp(node a,node b)
{
if(a.grade==b.grade)
return a.dead<b.dead;
return a.grade>b.grade;
}
int flag[1005];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,les=0;
memset(flag,0,sizeof(flag));
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&q[i].dead);
for(int i=0;i<n;i++)
scanf("%d",&q[i].grade);
sort(q,q+n,cmp);
for(int i=0;i<n;i++)
{
int f=0;
for(int j=q[i].dead-1;j>=0;j--)
{
if(flag[j]==0)
{
flag[j]=1,f=1;
break;
}
}
if(!f)
les+=q[i].grade;
}
printf("%d\n",les);
}
return 0;
}