汉诺塔VI
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 1422 Accepted Submission(s): 1010
Problem Description
n个盘子的汉诺塔问题的最少移动次数是2^n-1,即在移动过程中会产生2^n个系列。由于
发生错移产生的系列就增加了,这种错误是放错了柱子,并不会把大盘放到小盘上,即各柱
子从下往上的大小仍保持如下关系 :
n=m+p+q
a1>a2>...>am
b1>b2>...>bp
c1>c2>...>cq
计算所有会产生的系列总数.
发生错移产生的系列就增加了,这种错误是放错了柱子,并不会把大盘放到小盘上,即各柱
子从下往上的大小仍保持如下关系 :
n=m+p+q
a1>a2>...>am
b1>b2>...>bp
c1>c2>...>cq
计算所有会产生的系列总数.
Input
包含多组数据,首先输入T,表示有T组数据.每个数据一行,是盘子的数
目N<30.
目N<30.
Output
对于每组数据,输出移动过程中所有会产生的系列总数。
Sample Input
3 1 3 29
Sample Output
3 27 68630377364883
每个盘子都可以放错三次。
#include <iostream>
#include <cstdio>
using namespace std;
long long pow(int a,int b)
{
if(b==0)
{
return 1;
}
return a*pow(a, b-1);
}
int main()
{
int n;
int N;
cin>>N;
while (N--)
{
cin>>n;
cout<<pow(3,n)<<endl;
}
return 0;
}