hdu 1010 Tempter of the Bone

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 71708    Accepted Submission(s): 19747


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES

题意:输入一个n*m的迷宫,和一个T:可以在迷宫中生存的最大时间。S为起点,D为终点。并且,每个格子只能踩一次,且只能维持一秒,然后该块地板就会塌陷。所以你必须每秒走一步,且到D点时,所用时间为T。


#include<iostream>
using namespace std;
int flag;
int N,M,T;
int d[4][2]={{0,-1},{0,1},{1,0},{-1,0}};   //4个不同的方向
int x2,y2;
void DFS(char a[][10],int x,int y,int t)
{
    if(t==T && x==x2 && y==y2)
    {
        flag=1;     //已经找到了,标记返回,不用再继续搜了
        return;
    }
    int temp=abs(x-x2)+abs(y-y2);    //当前左边到目的地的需要走的步数
    if((T-t-temp)%2)       所需的步数与当前所剩的时间奇偶不一致是说明肯定到不了,返回
    {
        return;
    }
    for (int i=0; i<4; i++)   //向4个不同的方向进行搜索
    {
        if(a[x+d[i][0]][y+d[i][1]] !='X' && !flag) 
        {
            a[x+d[i][0]][y+d[i][1]]='X';
            DFS(a, x+d[i][0], y+d[i][1],t+1);  //向周围搜索
            a[x+d[i][0]][y+d[i][1]]='.';    //回溯
        }
    }
}
int main()
{
    int x1=0,y1=0;
    while (cin>>N>>M>>T && N)
    {
        char a[10][10];
        flag=0;
        memset(a, 'X', sizeof(a));
        for (int i=1; i<=N; i++)
        {
            for (int j=1; j<=M; j++)
            {
                cin>>a[i][j];
                if(a[i][j]=='S')
                {
                    x1=i;
                    y1=j;
                }
                if(a[i][j]=='D')
                {
                    x2=i;
                    y2=j;
                }
            }
        }
        a[x1][y1]='X';
        DFS(a,x1,y1,0);
        if(flag)
        {
            cout<<"YES"<<endl;
        }
        else
        {
            cout<<"NO"<<endl;
        }
    }
    return 0;
}

参考博客: http://acm.hdu.edu.cn/forum/read.php?tid=6158


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值