hdu 3405 World Islands(最小生成树)

Problem Description
Dubai is a haven for the rich. The government of Dubai finds a good way to make money. They built a lot of artificial islands on the sea and sell them. These islands are shaped into the continents of the world, so they are called “world islands”. All islands are booked out now. The billionaires who buy these islands wants to make friends with each other, so they want these islands all be connected by bridges. Bill Gates also has booked an island, but he is the only one who doesn’t want his island to be connected with other islands, because he prefer to travel on the sea on his old landing craft which is used in the Invasion of Normandy in World War II. Fortunately, Bill doesn’t care about which island is saved for him, so Dubai government can still find the best way to build the bridges. The best way means that the total length of the bridges is minimum. In a word, if there are n islands, what they should do is to build n–2 bridges connecting n-1 islands, and give the rest island to Bill Gates. They can give any island to Bill Gates. Now they pay you good money to help them to find out the best way to build the bridges. 
Please note;
1.An island can be considered as a point.
2.A bridge can be considered as a line segment connecting two islands.
3.A bridge connects with other bridges only at the islands.
 

Input
The first line is an integer indicating the number of test cases.
For each test case, the first line is an integer n representing the number of islands.(0<n<50)
Then n lines follow. Each line contains two integers x and y( -20 <= x, y <= 20 ) , indicating the coordinate of an island. 
 

Output
For each test case, output the minimum total length of the bridges in a line. The results should be rounded to 2 digits after decimal point, and you must keep 2 digits after the decimal point. 
 

Sample Input
  
  
2 5 0 0 1 0 18 0 0 1 1 1 3 0 0 1 0 0 1
 

Sample Output
  
  
3.00 1.00
 

题意:给你n个点的坐标,问你选出n-1个点使它们连通,并保证边的总长度最小。
枚举最小生成树
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
using namespace std;
const int MAX=55;
const double maxn=100000000.0;
double map[MAX][MAX];
double prime(int u0,int n)
{
    bool vis[MAX]={false};
    double Lowcost[MAX];
    double sum=0;
    vis[u0]=true;
    for (int i=0; i<n; i++)
    {
        Lowcost[i]=map[i][0];
    }
    vis[0]=true;
    if(u0==0)
    {
        for (int i=0; i<n; i++)
        {
            Lowcost[i]=map[i][1];
        }
        vis[1]=0;
    }
    for (int i=0; i<n-1; i++)
    {
        int k=-1;
        double Min=maxn;
        for (int j=0; j<n; j++)
        {
            if(!vis[j] && Min>Lowcost[j])
            {
                Min=Lowcost[j];
                k=j;
            }
        }
        if(k==-1)
        {
            break;
        }
        sum+=Min;
        vis[k]=true;
        for (int j=0; j<n; j++)
        {
            if(!vis[j] && Lowcost[j]>map[k][j])
            {
                Lowcost[j]=map[k][j];
            }
        }
    }
    return sum;
}
int main()
{
    int t,n;
    int x[MAX];
    int y[MAX];
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d",&n);
        for (int i=0; i<n; i++)
        {
            scanf("%d%d",&x[i],&y[i]);
        }
        
        for (int i=0; i<n; i++)
        {
            for (int j=0; j<n; j++)
            {
                map[i][j]=maxn;
            }
        }
        for (int i=0; i<n; i++)
        {
            for (int j=i+1; j<n; j++)
            {
               map[i][j]=map[j][i]=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
            }
        }
        
        double ans=maxn;
        for (int i=0; i<n; i++)
        {
            ans=min(ans,prime(i,n));
        }
        printf("%.2lf\n",ans);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值