hdu 2660 Accepted Necklace(dfs、dp)

Problem Description
I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won't accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.
 

Input
The first line of input is the number of cases. 
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace. 
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight. 
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000. 
 

Output
For each case, output the highest possible value of the necklace.
 

Sample Input
  
  
1 2 1 1 1 1 1 3
 

Sample Output
  
  
1
dfs

#include <iostream>
#include <stdio.h>
using namespace std;
struct node
{
    int v,w;
}num[24];
int N,K,W,ans;
void dfs(int i,int w,int v,int cnt)
{
    if(w>W)
    {
        return;
    }
    if(cnt==K || i==N)
    {
        if(w<=W)
        {
            if(ans<v)
            {
                ans=v;
            }
        }
        return;
    }
    dfs(i+1, w+num[i].w, v+num[i].v, cnt+1); //选
    dfs(i+1, w, v, cnt);  //不选
}
int main()
{
    int t;
    scanf("%d",&t);
    while (t--)
    {
        ans=-1;
        scanf("%d%d",&N,&K);
        for (int i=0; i<N; i++)
        {
            scanf("%d%d",&num[i].v,&num[i].w);
        }
        scanf("%d",&W);
        dfs(0, 0, 0,0);
        printf("%d\n",ans);
    }
    return 0;
}

背包问题变形

#include <iostream>
#include <stdio.h>
using namespace std;
struct node
{
    int v,w;
}num[24];
int N,K,W;
int dp[1001][24];
int main()
{
    int t;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d%d",&N,&K);
        for (int i=0; i<N; i++)
        {
            scanf("%d%d",&num[i].v,&num[i].w);
        }
        scanf("%d",&W);
        memset(dp, 0, sizeof(dp));
        for (int i=0; i<N; i++)
        {
            for (int w=W; w>=num[i].w; w--)
            {
                for (int j=1; j<=K; j++)
                {
                    dp[w][j]=max(dp[w][j],dp[w-num[i].w][j-1]+num[i].v);
                }
            }
        }
        printf("%d\n",dp[W][K]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值