poj 2886 Who Gets the Most Candies?(线段树-单点更新)

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers  N (0 <  N  ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3

题意:n个孩子按顺时针排列,每个人受伤都有一张牌,牌上有一个数字,从第k个孩子开始出队,出队的熊孩子卡上数字是K,则顺时针第k人是下一个出队的,负数则逆时针,第P个出队的会得到的糖果数是p的因子个数,输出得到最多糖果的人和他的糖果数,如果有多个,则输出最先出队的。

和poj 2828思路一样,在网上看到的需要用反素数来优化。至于什么是反素数,百度吧。


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
#define maxn 500010
const int antiprime[]={1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,
    1260,1680,2520,5040,7560,10080,15120,20160,25200,
    27720,45360,50400,55440,83160,110880,166320,221760,
    277200,332640,498960,554400,665280
};

const int factorNum[]={1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,
    64,72,80,84,90,96,100,108,120,128,144,160,168,180,
    192,200,216,224
};
struct node
{
    char name[15];
    int val;  //记录val
}num[maxn*3];
int Count[maxn*3];  //记录人数
void PushUp(int root)
{
    Count[root]=Count[root<<1]+Count[(root<<1)+1];
}
void Build(int L,int R,int root)
{
    Count[root]=R-L+1;
    if(L==R)
        return;
    int mid=(L+R)>>1;
    Build(L, mid, root<<1);
    Build(mid+1, R, (root<<1)+1);
}
int Update(int pos,int L,int R,int root)
{
    if(L==R)
    {
        Count[root]--;
        return L;
    }
    int mid=(L+R)>>1;
    int ans;
    if(pos<=Count[root<<1])
       ans=Update(pos, L, mid, root<<1);
    else
       ans=Update(pos-Count[root<<1], mid+1, R, (root<<1)+1); //注意这里是pos-Count[root<<1]
    PushUp(root);
    return ans;
    
}
int main()
{
    int n,k;
    while (scanf("%d%d",&n,&k)!=EOF)
    {
       
        for (int i=1; i<=n; i++)
        {
            scanf("%s%d",num[i].name,&num[i].val);
        }
        Build(1, n, 1);
        int cnt=0;
        while (cnt<35 && antiprime[cnt]<=n)
            cnt++;
        cnt--;
        int pos=0;
        num[0].val=0;
        for (int i=0; i<antiprime[cnt]; i++)
        {
            if(num[pos].val>0)
                k=((k+num[pos].val-2)%Count[1]+Count[1])%Count[1]+1;
            else
                k=((k+num[pos].val-1)%Count[1]+Count[1])%Count[1]+1;
            pos=Update(k,1,n,1);
        }
        printf("%s %d\n",num[pos].name,factorNum[cnt]);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值