hdu 1513 Palindrome(dp 回文子序列)

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4284    Accepted Submission(s): 1467


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
  
  
5 Ab3bd
 

Sample Output
  
  
2
 



给出一个字符串,问要将这个字符串变成回文串要添加最少几个字符。

思路:求正串和反串的最长公共子序列,再用原先串的长度相减即可。
如果dp数组都开成5000的话,会超内存。因为在转移方程中,dp数组的第一维i只可能受i-1的影响,所以这里我们可以用滚动数组,这样dp数组的第一维就只需开成2就可以了。
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
char s1[5005],s2[5005];
int dp[2][5005],n;
int lcs()
{
    memset(dp, 0, sizeof(dp));
    int x,y;
    for (int i=1; i<=n; i++)
    {
        for (int j=1; j<=n; j++)
        {
            x=i%2;
            y=1-x;
            if(s1[i-1]==s2[j-1])
                dp[x][j]=dp[y][j-1]+1;
            else
                dp[x][j]=max(dp[y][j], dp[x][j-1]);
        }
    }
    return dp[n%2][n];
    
}
int main()
{

    while (scanf("%d",&n)!=EOF)
    {
        scanf("%s",s1);
        for (int i=0; i<n; i++)
            s2[i]=s1[n-i-1];
        
        s2[n]=0;
        printf("%d\n",n-lcs());
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值