hduoj1395!【水题】

/*2^x mod n = 1
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11690    Accepted Submission(s): 3640


Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.

Input
One positive integer on each line, the value of n.

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.

Sample Input
2
5
 
Sample Output
2^? mod 2 = 1
2^4 mod 5 = 1
 
Author
MA, Xiao
 
Source
ZOJ Monthly, February 2003 
*/
#include<stdio.h>
int main()
{
	int n , i, j;
	while(scanf("%d", &n) != EOF)
	{
		if( !(n&1) || n == 1)
		printf("2^? mod %d = 1\n", n);
		else
		{
			j = 1;
			for(i = 1; ; i++)
			{
				j *= 2;
				j %= n;
				if(j == 1)
				break;
			}
			printf("2^%d mod %d = 1\n", i, n);
		}
	}
	return 0;
}

题意:给出一个n,求最小的x使得2^x mod n =  1

思路:当n为奇数时,必定存在一个2的i次方 mod n = 1.当n为偶数时,由于偶数对偶数取余,余数必定是偶数,所以偶数不存在,还有当n=1时也不存在(特殊数字)。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值