Hduoj1312【广搜】

/*Red and Black
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10126    Accepted Submission(s): 6316


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a
 tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of 
tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself) 

Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
 

Sample Output
45
59
6
13
 

Source
Asia 2004, Ehime (Japan), Japan Domestic 
*/ 
#include<stdio.h>
#include<string.h>
int vis[22][22], q[450], n, m, dx[4] = {-1, 1, 0 , 0}, dy[4] = {0, 0, -1, 1};
char map[22][22];
int bfs(int x, int y)
{
	memset(vis, 0, sizeof(vis));//初始化 
	int front  = 0, rear  = 0, num = 1, u;
	u = x*m+y; 
	vis[x][y] = 1;//标记 
	q[rear++] = u;//入队起点 
	while(front < rear)
	{
		u = q[front++];//逐个取出队列元素 
		x = u/m;
		y = u%m; 
		for(int d = 0; d < 4; d++)//遍历四个方向 
		{
			int nx = x+dx[d], ny = y+dy[d];
			if(nx >= 0 && nx < n && ny >= 0 && ny < m && map[nx][ny] == '.' && !vis[nx][ny])//若边界内 且为黑 为访问 
			{
				num++;   //结果加1 
				vis[nx][ny] = 1;//标记以访问 
				int v = nx*m+ny; 
				q[rear++] = v;//入队
			}
		}
	}
	return num;
}
int main()
{
	int x, y;
	while(scanf("%d%d", &m, &n) != EOF && (n || m))
	{
		for(int i = 0 ; i < n; i++)
		{
			scanf("%s", map[i]);
			if(strchr(map[i], '@'))
			{
				for(int j = 0; j < m; j++)
				if(map[i][j] == '@')//保存起点 
				{
					x = i;
					y = j;
					break;
				}
			}
		}
		printf("%d\n", bfs(x, y));
	}
	return 0;
}

题意:给出一个矩阵,包含起点和‘.', '#', 求从起点开始,能够经过多少个‘.’,‘#’是墙。

思路:遍历矩阵,从起点开始遍历,遇到一个点就将答案加1,知道无法遍历或遍历完成为止,输出答案。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值