Hduoj1698【线段树】

/*Just a Hook
Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18439    Accepted Submission(s): 9241


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several 
consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic 
sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is 
calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second 
line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to 
Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.


Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.


Sample Input
1
10
2
1 5 2
5 9 3
 

Sample Output
Case 1: The total value of the hook is 24.
 

Source
2008 “Sunline Cup” National Invitational Contest 
 

Recommend
wangye   |   We have carefully selected several similar problems for you:  1542 1394 2795 1255 1828 
*/ 
#include<stdio.h>
int a[400000], mark[400010];//mark标记种类 
void build(int i, int l ,int r)//建立二叉树 
{
	mark[i] = 0;    //初始化为0 
	if(l == r)
	{
		a[i] = 1;// 叶子节点的值初始化为1 
		return;
	}
	int k = (l+r)>>1;
	build(i<<1, l, k);//建立左子树 
	build(i<<1|1, k + 1, r);//建立右子树 
	a[i] = a[i<<1] + a[i<<1|1];//回溯求二叉树各节点值 
}
void Pushdown(int i, int c)//标记下沉 
{
	if(mark[i])  //如果有标记 
	{
		mark[i<<1] = mark[i<<1|1] = mark[i];//改变子节点的标记 
		a[i<<1] = (c - (c>>1))*mark[i];//算出子节点改变后的值 
		a[i<<1|1] = (c>>1) * mark[i];
		mark[i] = 0;
	}
}
void update(int i, int l, int r, int L, int R, int num)
{
	if(l <= L && r >= R)//如果更新区间包含该节点的区间 
	{
		mark[i] = num;  //标记 
		a[i] = num * (R-L+1);//改变值 
		return ;
	}
	Pushdown(i, R-L+1);
	int k = (L+R)>>1;
	if(l <= k)//如果查询区间和左子树有交集继续更新 
		update(i<<1, l, r, L, k, num);
	if(r >= k+1 )//与右子树有交集 
		update(i<<1|1, l, r, k+1, R, num);
	a[i] = a[i<<1] + a[i<<1|1];//更新完后回溯更新值 
}
int main()
{
	int i, j, k, T, m, n;
	scanf("%d", &T);
	for(int cas = 1; cas <= T; cas++)
	{
		scanf("%d%d", &n, &m);
		build(1, 1, n);
		while(m--)
		{
			scanf("%d%d%d", &i, &j, &k);
			update(1, i, j, 1, n, k);
		}
		printf("Case %d: The total value of the hook is %d.\n", cas, a[1]);//输出总和 
	} 
	return 0;
}

题意:有1到n个勾,勾有三种材质,每种材质所能获得的值分别为1,2,3,给出勾的个数以及对勾的操作,求最后的总和。

思路:就是用线段树去求,对于区间值的改变有利于统计。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值