Hduoj2844【多重背包】

/*Coins
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9140    Accepted Submission(s): 3671

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were 
some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known 
the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value 
A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 
 
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).
The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test 
case is followed by two zeros. 
 
Output
For each test case output the answer on a single line. 
 
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output
8
4
 
Source
2009 Multi-University Training Contest 3 - Host by WHU 
 
Recommend
gaojie   |   We have carefully selected several similar problems for you:  1864 2845 2870 2577 2830 
*/ 
#include<stdio.h>
#include<string.h>
int dp[100010],  c[101][2];
int n, m;
int max(int x, int y)
{
	return x>y?x:y;
}
int main()
{
	int i, j, k;
	while(scanf("%d%d",&n, &m) != EOF && ( n || m))
	{
		for(i = 0; i < n; ++i)
		scanf("%d", &c[i][0]);
		for(i = 0; i < n; ++i)
		scanf("%d", &c[i][1]);
		memset(dp, 0, sizeof(dp));
		
		for(i = 0; i < n; ++i)
		{
			if(c[i][0]*c[i][1] >= m)
			{
				for(j = c[i][0]; j <= m; ++j)
				dp[j] = max(dp[j], dp[j-c[i][0]] + c[i][0]);
			}
			else
			{
				k = 1;
				while(k < c[i][1])
				{
					for(j = m; j >= k*c[i][0]; --j)
					dp[j] = max(dp[j], dp[j - k*c[i][0]] + k*c[i][0]);
					c[i][1] -= k;
					k *= 2;
				}
				for(j = m; j >= c[i][1]*c[i][0]; j--)
				dp[j] = max(dp[j], dp[j - c[i][1]*c[i][0]] + c[i][1]*c[i][0]);
			}
		}
		int sum = 0;
		for(i = 1; i <= m; ++i)
		if(dp[i] == i)
		sum++; 
		printf("%d\n", sum);
	}
	return 0;
}


题意:托尼有n种硬币,每种硬币都有若干个,现在他想要买手表,只知道表的最大价值不会超过m,且要求买的表的价值不用找零,求有多少个方法。

思路:当硬币的价值乘于它的数量不超过m时视为01背包,若超过则视为完全背包,这里将硬币的价值和容量看作是同一个变量,最后求得的dp【i】值即表示对于第i个价值托尼手中的硬币多能表示的最大值是多少,若恰好等于i则说明不用找零,即为一种方法。这里还有一个就是01背包的二进制优化~~将硬币的个数优化成二进制的能表示的所有种类,节省时间。

难点:要想到将硬币的价值即看作是容量又是价值,最后进行dp,获取dp【i】 = i的解。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值