Hduoj2489【最小生成树+DFS】

Minimal Ratio Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3262    Accepted Submission(s): 990


Problem Description
For a tree, which nodes and edges are all weighted, the ratio of it is calculated according to the following equation.




Given a complete graph of n nodes with all nodes and edges weighted, your task is to find a tree, which is a sub-graph of the original graph, with m nodes and whose ratio is the smallest among all the trees of m nodes in the graph.
 

Input
Input contains multiple test cases. The first line of each test case contains two integers n (2<=n<=15) and m (2<=m<=n), which stands for the number of nodes in the graph and the number of nodes in the minimal ratio tree. Two zeros end the input. The next line contains n numbers which stand for the weight of each node. The following n lines contain a diagonally symmetrical n×n connectivity matrix with each element shows the weight of the edge connecting one node with another. Of course, the diagonal will be all 0, since there is no edge connecting a node with itself.



All the weights of both nodes and edges (except for the ones on the diagonal of the matrix) are integers and in the range of [1, 100].

The figure below illustrates the first test case in sample input. Node 1 and Node 3 form the minimal ratio tree.

 

Output
For each test case output one line contains a sequence of the m nodes which constructs the minimal ratio tree. Nodes should be arranged in ascending order. If there are several such sequences, pick the one which has the smallest node number; if there's a tie, look at the second smallest node number, etc. Please note that the nodes are numbered from 1 .
 

Sample Input
  
  
3 2 30 20 10 0 6 2 6 0 3 2 3 0 2 2 1 1 0 2 2 0 0 0
 

Sample Output
  
  
1 3 1 2
 

Source
#include<stdio.h>
#include<string.h>
int node[16], weight[16][16], cnt[16];
int n, m, ans[16], vis[16], sum1, sum2, num;
double mi;
int min(int x, int y)
{
	return x<y?x:y;
}
void search()
{
	int d[16], i, j, k;
	sum1 = 0;
	sum2 = 0;
	memset(vis, 0, sizeof(vis));
	for(i = 1; i <= m; ++i)
	d[cnt[i]] = weight[cnt[1]][cnt[i]];//初始化所有点到1号点的距离
	vis[cnt[1]] = 1;
	for(i = 1; i < m; ++i)
	{
		int temp = 10000000;
		for(j = 1; j <= m; ++j)
		{
			if(!vis[cnt[j]] && d[cnt[j]] < temp)//找出离1号点的集合距离最小的点
			{
				temp = d[cnt[j]];
				k = cnt[j];
			}
		}
		sum1 += temp;//将距离加入权值和中
		vis[k] = 1;//将当前找到的点也拉入1号集合
		for(j = 1; j <= m; ++j)
		{
			if(!vis[cnt[j]])
			d[cnt[j]] = min(d[cnt[j]], weight[k][cnt[j]]);//更新剩余点到1号集合的距离
		}
	}
	for(i = 1; i <= m; ++i)
	sum2 += node[cnt[i]];
	double temp1 = (double)sum1 / (double)sum2;
	if(temp1 < mi)
	{
		mi = temp1;
		for(i = 1; i <= m; ++i)
		ans[i] = cnt[i];
	}
} 
void dfs(int x)
{
	int i, j, k;
	if(num == m)
	{
		search();
		return ;
	}
	for(i = x+1; i <= n; ++i)
	{
		num++;
		cnt[num] = i;
		dfs(i);
		num--;
	}
}
int main()
{
	int i, j, k;
	while(scanf("%d%d", &n, &m) != EOF && (n || m))
	{
		for(i = 1; i <= n; ++i)
		scanf("%d", &node[i]); 
		for(i = 1; i <= n; ++i)
		{
			for(j = 1; j <= n; ++j)
			{
				scanf("%d", &weight[i][j]);
			}
		}
		mi = 100000000.0;
		for(i = 1; i <= n; ++i)
		{
			num = 1;
			cnt[num] = i;
			dfs(i);
		}
		for(i = 1; i < m; ++i)
		printf("%d ", ans[i]);
		printf("%d\n", ans[m]);
	}
	return 0;
}

题意:给出一个完全树,共有n个节点并且任意2个点之间都有一条带权边,现在要求从中找一个m个节点的完全树,要求边权值的和除以节点值的和最小,并且输出这m个节点的编号。
思路:首先得理解这完全树的边权值的和的求法,原谅我这里不知道该怎么解释这个权值和的求法,然后就是深搜所有的情况,求出ratio的值,最后这里有个要注意的地方就是要用double来定义浮点数。
难点:边权值得求和。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值