Hduoj1023【卡特兰数】

/*Train Problem II
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6811    Accepted Submission(s): 3690


Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in 
strict-increasing order, how many orders that all the trains can get out of the railway.

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

Output
For each test case, you should output how many ways that all the trains can get out of the railway.

Sample Input
1
2
3
10

Sample Output
1
2
5
16796

Hint
The result will be very large, so you may not process it by 32-bit integers.
 
Author
Ignatius.L
*/
#include<stdio.h>
#include<string.h> 
int h[101][121];
int main()
{
    int i,j,k,l,n;
    memset(h, 0, sizeof(h));
    h[0][1]=1;
	h[1][1]=1;
    for(i = 2; i <= 100; ++i)//求第i个卡特兰数 
    {
        for(j = 0; j < i; ++j)//断点 
        //大数乘法 
            for(k = 1; k < 60; ++k)//第j个的第k位 * 第i-j-1的每一位 
            for(l = 1; l < 60; ++l)
        	h[i][k + l - 1] += h[j][k] * h[i - j - 1][l];
        for(j = 1; j < 60; ++j)//进位 
        {
            h[i][j + 1] += h[i][j] / 10;
            h[i][j] %= 10;
        }
    }
    while(scanf("%d", &n) != EOF)
    {
        i=60;
		while( h[n][--i] == 0 )
		; 
        for(j = i; j > 0; --j)//输出 
		printf("%d", h[n][j]);
        printf("\n");
    }
    return 0;
}

题意:火车按照严格递增的序列进站,求有多少种出战的顺序。

思路:假设第k节火车最后出站,那么比k小的数必须先出站,然后k进站,剩下的也必须在k之前出站,相当于说对于某个n,f【n】 = f【n-k-1】 * f【k-1】,而k由1~n进行遍历。由于f【n】较大,所以要用大数相乘,开一个二位数组,第一位保存n第二位保存答案。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值