Hduoj1035【水题】

/*Robot Motion
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8167    Accepted Submission(s): 3765

Problem Description

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move 
are laid down in a grid. The possible instructions are 

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is 
shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, 
and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.


Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three 
integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column 
in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the 
rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines 
of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the 
grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the 
instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates 
the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.


Sample Input
3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 
 

Sample Output
10 step(s) to exit
3 step(s) before a loop of 8 step(s)

Source
Mid-Central USA 1999 

Recommend
We have carefully selected several similar problems for you:  2553 1258 1045 2660 1181 
*/
#include<stdio.h>
#include<string.h>
char grid[11][11];
int vis[11][11], road[110][2], num, ok, n, m;
void dfs(int x, int y)
{
	if(x < 1 || x > n || y < 1 || y > m)
	{
		ok = 1;
		return ;
	}
	if(!vis[x][y])
	vis[x][y] = 1;
	else
	{
		road[num][0] = x;
		road[num++][1] = y;
		return ;
	}
	road[num][0] = x;
	road[num++][1] = y;
	if(grid[x][y] == 'W')
	{
		dfs(x, y-1);
	}
	else if(grid[x][y] == 'E')
	{
		dfs(x, y+1);
	}
	else if(grid[x][y] == 'S')
	{
		dfs(x+1, y);
	}
	else
	{
		dfs(x-1, y); 
	}
}
int main()
{
	int i, j, k, start;
	while(scanf("%d%d%d", &n, &m, &start) != EOF)
	{
		if( n == 0 && m == 0 && start == 0)
		break;
		getchar();
		for(i = 1; i <= n; ++i)
		{
			for(j = 1; j <= m; ++j)
			scanf("%c", &grid[i][j]);
			getchar();
		}
		memset(vis, 0, sizeof(vis));
		num = 0;
		ok = 0;
		dfs(1, start);
		if(!ok)
		{
			for(i = 0; i < num-1; ++i)
			{
				if(road[i][0] == road[num-1][0] && road[i][1] == road[num-1][1])
				break;
			}
			printf("%d step(s) before a loop of %d step(s)\n", i, num - i - 1);
		}
		else
		{
			printf("%d step(s) to exit\n", num);
		}
	}
} 


题意:给出一个矩阵由‘w’, ‘E’,‘S’,‘N’四个方向构成,然后给出第一行某一列的出发位置,根据方向来移动,求是否能否走出矩阵,若能输出步数,若不能则输出出现循环前的步数以及循环的步数。

思路:说白了就是模拟,这里一遍模拟一遍保存路径,最后按照题目要求输出就是了,格式是不变的。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值