Hduoj1078【搜索】



FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6648    Accepted Submission(s): 2733


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
 

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
 

Sample Input
  
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
  
  
37
 

Source
#include<stdio.h>
#include<string.h>
int  dx[4] = {0,0,1,-1}, dy[4] = {1, -1, 0, 0}, map[101][101];
int n, m, max[101][101];
int dfs(int x, int y)
{
    int i, j;
    if(!max[x][y])
    {
        int sum = 0;
        for(i = 1; i <= m; ++i)
        for(j = 0; j < 4; ++j)
        {
            int nx = x + i*dx[j];
            int ny = y + i*dy[j];
            if(nx >= 0 && nx < n && ny >= 0 && ny < n  && map[nx][ny] > map[x][y])
            {

                int temp;
                temp = dfs(nx, ny);
                if(temp > sum)
                sum = temp;
            }
        }
        max[x][y] = sum + map[x][y];
    }
    return max[x][y];
}
int main()
{
    int i, j, k;
    while(scanf("%d%d", &n, &m) != EOF && n > 0 && m > 0)
    {
        for(i = 0; i < n; ++i)
        for(j = 0; j < n; ++j)
        scanf("%d", &map[i][j]);
        memset(max, 0, sizeof(max));
        printf("%d\n", dfs(0, 0));
    }
    return 0;
}

题意:有一个网格,每个格子有0~100个奶酪,老鼠从(0,0)开始觅食,老鼠每次可以横向或着竖向移动,每次移动最多不能超过k格,并且每次移动要求目的格子要比当前格子的奶酪数要大,求最多能吃到多少奶酪。
思路:很明显是搜索,但是普通的搜索很容易超时,这里有个诀窍就是对于每次搜索我们可以保存以当前格子为起点所能吃到的最大奶酪数,然后回溯保存当前点的最大奶酪数,直接返回到起点所能吃到的最大奶酪数。
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值