Hduoj1535【SPFA】

/*Invitation Cards
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2921    Accepted Submission(s): 1367


Problem Description
In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 
The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 


 

Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop. 

 

Output
For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers. 

 

Sample Input
2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50
 

Sample Output
46
210
 

Source
Central Europe 1998 
*/ 
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define INF 99999999
int N, n, m;
int first[1000010],next[1000010], que[1000010],d[1000010];
bool vis[1000010];
struct road
{
	int u, v, w;
}R[1000010];

void spfa()
{
	for(int i = 0; i <= n; ++i)
	d[i] = INF;
	d[1] = 0;
	int front = 0, rear = 0;
	que[rear++] = 1;
	memset(vis, 0, sizeof(vis));
	while(front < rear)
	{
		int u = que[front++];
		vis[u] = false;//出队 
		//从该结点引出的最后一条边开始  
		for(int k = first[u]; k != -1; k = next[k])
		{
			int v = R[k].v;
			if(d[v] > d[u] + R[k].w)//更新最短距离 
			{
				d[v] = d[u] + R[k].w; 
				if(!vis[v])     //将更新的点加入队列以便后继更新  
				{
					que[rear++] = v;
					vis[v] = true;
				}
			}
		}
	}
}

//逆向构图 
void rebuild()
{
	memset(first, -1, sizeof(first));
	memset(next, -1, sizeof(next));
	for(int i = 0; i < m; ++i)
	{
		int v = R[i].v;
		R[i].v = R[i].u;
		R[i].u = v;
		next[i] = first[v];
		first[v] = i;
	}
} 

int main()
{
	int i, j, k, ans;
	scanf("%d", &N);
	while(N--)
	{
		memset(first, -1, sizeof(first));
		memset(next, -1, sizeof(next));
		scanf("%d%d", &n, &m);
		for(i = 0; i < m; ++i)
		{
			//保存 u结点所引出的边的编号 
			scanf("%d%d%d", &R[i].u, &R[i].v, &R[i].w);
			next[i] = first[R[i].u];//刚开始为-1即没有  否则将保存u结点在本次出度边之前的最后一条出度边的编号 下面更新保存本次出度边 
			first[R[i].u] = i;//first保存的是u结点的最后一条出度边 
		}
		ans = 0;
		spfa();
		for(i = 2; i <= n; ++i)
		ans += d[i];
		rebuild();
		spfa(); 
		for(i = 2; i <= n; ++i)
		ans += d[i];
		printf("%d\n", ans);
	}
	return 0;
}


题意:有n个汽车站,每个车站都需要一个学生站岗,每个学生都从1号车站出发到达其他汽车站,然后再从相应的汽车站返回1号汽车站,每个车站到达其他车站都有相应的路线和路费,现在要求计算学生们所需的最小的资金。

思路:这里有2个最小的路径,一个是1号车站到其他车站的最小路径,一个是其他车站到1号车站的最小路径,然而2个车站之间来回的消费是不同的,所以要进行2次的spfa算法,其中一次需要对图的路径进行反向构图并交换车站,再用spfa即可求出第二种路径的消费。这里最难的便是构图,由于百万的数据量所以无法用邻接表来保存两两之间的费用,然而这里的边却最多只有一百万条,我们可以根据边来统计车站到车站之间的距离(具体可以看代码理解)。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值