1014. Waiting in Line (30)

102 篇文章 0 订阅
9 篇文章 0 订阅

1014. Waiting in Line (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry
N个窗口,每个窗口黄线内M名;
当这些窗口未满时,排满(人数短的先排,即分别排1个,当都是一个,排两个……直到都排满)
新进的人处理结束的时间=当前队列最后一个处理结束的时间+新进人处理时间
当排满后要在进入,即这些队伍中的某一队头一个最快处理结束,新进的进到此队列,当有两个或以上的队有同最快处理结束,窗口编号靠前的先。
输出:!!如果这个人在17:00之前入队不包括(17:00),那么输出这个人处理结束时间;
否则Sorry。

 

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
7月27日 10:04答案正确301014C++ (g++ 4.7.2)3312datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确130812/12
1答案正确13084/4
2答案正确11803/3
3答案正确13083/3
4答案正确13084/4
5答案正确33124/4
#include<iostream>   
#include<iomanip>
using namespace std;   
#define DonEtime 540
struct CustomerLine
{ 
  int T; 
  int starT;
}; 
void StarCl(CustomerLine*Customer,int Y_Y,int ST,int ED)
{ 
  while (ST < ED)
  {
    Customer[ST++].T =   Y_Y; 
  }
}
void STARt(int*H_H, int des, int ST, int ED)
{
  while (ST < ED)
  {
    H_H[ST++] = des;
  }
}
int FindLine(CustomerLine*Customer, int**Line, int*head, int thisline, int N)
{
  int i,min;
  min =Line[thisline][head[thisline]];
  for (i = 1; i < N; i++)
  {
    if (Line[i][head[i]]<min)
    {
      min = Line[i][head[i]];
      thisline = i;
    }
  }
  return thisline;
}
void FullTheLine(CustomerLine*Customer, int*Line,  int*sail, int thisline, int now, int M,int time)
{ 
  int last;
  last =(sail[thisline] - 1 + M) % M;
  Customer[now].T = time + Line[last]; 
  Line[sail[thisline]] = Customer[now].T;
  sail[thisline] = (sail[thisline] + 1) % M;
  
}
int main()
{  
  CustomerLine*Customer;
  int index, N, M, K, Q, temp, thisline;
  int** Line;
  int*head;
  int*sail;
  cin >> N >> M >> K >> Q;
  Customer = new CustomerLine[K];
  head = new int[N];
  sail = new int[N];
  Line = new int*[N];
  for (index = 0; index < N; index++)
  {
    Line[index] = new int[M];
      STARt(Line[index], 0, 0, M);
  } 
  StarCl(Customer,0, 0, K);
  STARt(head, 0, 0, N);
  STARt(sail,0, 0, N);
  for (index = 0,temp=N*M; index < K; index++)
  {
    cin >> Customer[index].starT ; 
    if (index < temp)
    {
      thisline = index% N;
      FullTheLine(Customer, Line[thisline], sail, thisline, index, M, Customer[index].starT);
    }
    else
    {
      thisline = FindLine(Customer, Line, head, 0, N); 
      head[thisline] = (head[thisline] + 1) % M;
      FullTheLine(Customer, Line[thisline], sail, thisline, index, M, Customer[index].starT);
    }
  } 
  for (index = 0; index < Q; index++)
  {
    cin >> temp;
    temp--;
    if (Customer[temp].T - Customer[temp].starT < DonEtime)
    {
      cout << setw(2) << setfill('0') << Customer[temp].T / 60 + 8 << ":" << setw(2) << setfill('0') << Customer[temp].T % 60 << endl;
    }
    else cout << "Sorry" <<endl;

  }
  system("pause"); 
  for (index = 0; index <N; index++)
  {
    delete[] Line[index];
  }
  delete[] Line;
  delete[] sail;
  delete[] head;
  delete[] Customer;
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值