1024. Palindromic Number (25)

102 篇文章 0 订阅
26 篇文章 0 订阅

1024. Palindromic Number (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3
输入N  K
steps=0
①看N是不是对称,是③;否则steps++,
②若steps<K,令 N :=N + N的数字反过来①;否则③
③输出此时的N,和steps

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
7月30日 18:50答案正确251024C++ (g++ 4.7.2)1436datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确13083/3
1答案正确13083/3
2答案正确14363/3
3答案正确11802/2
4答案正确13082/2
5答案正确11803/3
6答案正确11803/3
7答案正确11802/2
8答案正确13084/4
#include<iostream>     
#include<string>
using namespace std;  
bool IsPalindromic(string str)
{
  int index,len;
  len = str.size()-1;
  for (index = 0; index <= len; index++, len--)
    if (str[index] != str[len])return false;
  return true;
}
void str1_str2(string*str, int from, int to)
{
  int c, index, len;
  char strctemp;
  len = str[from].size()-1;
  str[to] = "\0";
  for (index = 0,c=0; index <=len; index++)
  {
    c+=str[from][index] - '0' + str[from][len - index] - '0';
    strctemp = c % 10 + '0';
    str[to] = strctemp + str[to];
    c /= 10; 
  }
  if (c !=  0)
  {
    strctemp = c + '0';
    str[to] = strctemp + str[to]; 
  }
}
int main()
{   
  string str[2];
  bool Flag;
  int  index,  K, tag=0;
  cin >> str[tag] >> K;
  Flag = true;
  index = 0;
  do 
  {
    if (IsPalindromic(str[tag]))
    { 
      Flag = false;
    }
    else
    {
      str1_str2(str, tag, 1 - tag);
      tag = 1 - tag;
      index++;
    }
  }while (index < K&&Flag);
  cout << str[tag] << endl << index << endl;
  system("pause");   
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值