1047. Student List for Course (25)

102 篇文章 0 订阅
37 篇文章 0 订阅
 

1047. Student List for Course (25)

时间限制
400 ms
内存限制
64000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
共有N个学生,K门课(编号1~K)
学生姓名  选课数  选的课的编号
用到vector  ,sort,string,如果用cin  cout就过不了,然后string的printf scanf又是硬伤。
下面两个代码,一个是先到各科里面,然后要输出前排一下;用的内存较少;
一个是报全部的按名字排好序,再一个个把名单送到各科

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月10日 11:38答案正确251047C++ (g++ 4.7.2)26117228datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确130415/15
1答案正确12963/3
2答案正确11803/3
3答案正确261172284/4
#include<iostream> 
#include<algorithm>
#include<string> 
#include<vector>
using namespace std;  
bool NameCMp(const string&A, const string&B)
{
  return A <B;
}
void readln(vector<vector<string> > *courses, int N)
{ 
  int C,course;
  char name[5];
  string nm;
  while (N--)
  {
    scanf("%s%d",name,&C);
    nm = name;
    while (C--)
    {
      scanf("%d", &course);
      (*courses)[course].push_back(nm);
    } 
  }

} 
void DisplaY(vector<vector<string> >*courses, int K)
{
  int index;
  for ( index = 1; index <= K; index++)
  { 
    printf("%d %d\n", index, (*courses)[index].size());
    sort((*courses)[index].begin(), (*courses)[index].end(), NameCMp);
    for (vector<string> ::iterator iter = (*courses)[index].begin(); iter != (*courses)[index].end(); iter++)
      printf("%s\n", (*iter).c_str());
  }
}
int main()
{ 
  int N,  K;  
  scanf("%d%d", &N, &K); 
  vector<vector<string> >courses(K + 1);
  readln(&courses, N);
  DisplaY(&courses, K);
  system("pause");
  return 0;
}

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月10日 11:10答案正确251047C++ (g++ 4.7.2)17524116datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确124815/15
1答案正确13043/3
2答案正确13843/3
3答案正确175241164/4

#include<iostream> 
#include<algorithm>
#include<string>
#include<string.h>
#include<vector>
using namespace std; 
struct stu
{
  char name[5];
  vector<int> cs;
};
bool NameCMp(const stu&A, const stu&B)
{
  return strcmp(A.name, B.name) < 0;
}
void readln(vector<stu>*student, int N)
{ 
  int C,course;
  while (N--)
  {
    scanf("%s%d", (*student)[N].name, &C); 
    while (C--)
    {
      scanf("%d", &course);
      (*student)[N].cs.push_back(course);
    }
  }

}
void MatchTo(vector<stu>*student, int N, vector<vector<string>>*courses)
{
  int len,index;
  string name;
  for (index = 0; index < N; index++)
  {
    name = (*student)[index].name;
    len = (*student)[index].cs.size();
    while (len--)
      (*courses)[(*student)[index].cs.operator[](len)].push_back(name);
  }
}
void DisplaY(vector<vector<string>>*courses, int K)
{
  int index;
  for ( index = 1; index <= K; index++)
  { 
    printf("%d %d\n",index , (*courses)[index].size()); 
    for (vector<string> ::iterator iter = (*courses)[index].begin(); iter != (*courses)[index].end(); iter++)
      printf("%s\n", (*iter).c_str());
  }
}
int main()
{ 
  int N,  K;  
  scanf("%d%d", &N, &K);
  vector<stu>student(N);
  readln(&student, N);
  sort(student.begin(),student.end(),NameCMp);
  vector<vector<string>>courses(K + 1);
  MatchTo(&student, N,&courses);
  DisplaY(&courses, K);
  system("pause");
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值