078. Hashing (25)

102 篇文章 0 订阅
2 篇文章 0 订阅

078. Hashing (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -
提供Msize大小的哈希表(编号从0~Msize-1)  有N个要填入的值
接着是N个要填入的值 key1  key2 ……
首先找到一个质素,prime>=Msize;这个质素是最接近Msize的;令这个Msize=这个质素(只能被1和它本身整除的正整数);
hash    
   按照输入的key顺序,inner从0到Msize-1如果pos=(key+inner*inner)%Msize;
                                    一发现有table[pos]还没有放东西,就输出这个pos并置满;
                                    若都有放东西,就“-”

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月17日 00:19答案正确251078C++ (g++ 4.7.2)21384datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确118012/12
1答案正确12483/3
2答案正确13085/5
3答案正确213845/5

#include<iostream>  
#include<vector> 
#include<math.h>
using namespace std;
int largerMsizeFirstPrime(int Msize)
{
  if (Msize <= 2)return 2;
  bool nofind=true;
  int i;
  while (nofind)
  {
    int eNd = sqrt(Msize); 
    for (i = 2; i <= eNd&&Msize%i != 0; i++)
      ;
    if (i> eNd)nofind = false;
    else Msize++;

  }
  return Msize;
}
int main()
{
  int N,Msize,data,pos,index;  
  cin >> Msize >>N; 
  Msize = largerMsizeFirstPrime(Msize);
  vector<bool>table(Msize, true); 
  for (index = 0; index < N;index++)
  {
        cin >> data;   
      int inner = 0;
      do
      {
        pos = (data + inner*inner) % Msize;
        inner++;
      } while (!table[pos] && inner < Msize);
      if (inner== Msize)
      {
        if (index>0)cout << " ";
        cout <<"-";
      }
      else
      { 
        table[pos] = false;
        if (index>0)cout << " ";
        cout << pos;
      }  
  }
  cout << endl;
    system("pause");
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值