1104. Sum of Number Segments (20)

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:
4
0.1 0.2 0.3 0.4 
Sample Output:
5.00
num 输入队列有多少个数
依次输入num个in,都是不大于1.0的小数,
要求输出这个队列非空子串的和,保留两位小数,有没有换行符结束都可以通过。
注意:如果 sum += (num - i + 1)*i*in;就有两个错误,详见后面。double型in要在前面,可能是数据大溢出了吧
串的各部分术语http://xujiayu317.blog.163.com/blog/static/25475209201601895222262/
评测结果
时间 结果 得分 题目 语言 用时(ms) 内存(kB) 用户
6月05日 11:43 答案正确 20 1104 C++ (g++ 4.7.2) 119 628 datrilla

测试点

测试点 结果 用时(ms) 内存(kB) 得分/满分
0 答案正确 3 512 12/12
1 答案正确 4 512 3/3
2 答案正确 119 604 3/3
3 答案正确 63 628 2/2

#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
  double sum=0, in;
  int num;
  cin >> num;
  for (int i = num; i > 0; i--)
  {
    cin >> in;
    sum += in*(num - i + 1)*i;
  }
  cout << setiosflags(ios::fixed) << setprecision(2)
    << sum ;
  system("pause");
  return 0;
}

评测结果

时间 结果 得分 题目 语言 用时(ms) 内存(kB) 用户
6月05日 11:42 部分正确 15 1104 C++ (g++ 4.7.2) 96 624 datrilla

测试点

测试点 结果 用时(ms) 内存(kB) 得分/满分
0 答案正确 3 512 12/12
1 答案正确 3 512 3/3
2 答案错误 92 512 0/3
3 答案错误 96 624 0/2
#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
  double sum=0, in;
  int num;
  cin >> num;
  for (int i = num; i > 0; i--)
  {
    cin >> in;
    sum += (num - i+1)*i*in;
  }
  cout << setiosflags(ios::fixed) << setprecision(2)
    << sum ;
  system("pause");
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值