1106. Lowest Price in Supply Chain (25)

102 篇文章 0 订阅
37 篇文章 0 订阅

1106. Lowest Price in Supply Chain (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
Sample Output:
1.8362 2

这一题的类型感觉去年做了好几次了。但是这次还是会细节问题


N(三种商人)  price(厂家价格)  r(每转手一家,价格(1+r%))

ki个  ID[1]……ID[ki]


[其中ID从0到N-1,ID[]=0代表厂家]

问题求的是没有转手的那些商家【零售商】,价格最低是多少【min】,且达到最低价格的有几家【num】

输出

min  num

评测结果

时间 结果 得分 题目 语言 用时(ms) 内存(kB) 用户
7月08日 16:39 答案正确 25 1106 C++ (g++ 4.7.2) 80 5880 datrilla

测试点

测试点 结果 用时(ms) 内存(kB) 得分/满分
0 答案正确 2 372 11/11
1 答案正确 2 384 1/1
2 答案正确 72 3044 2/2
3 答案正确 80 5880 2/2
4 答案正确 4 384 3/3
5 答案正确 76 4340 2/2
6 答案正确 80 4480 2/2
7 答案正确 80 5856 2/2

#include<iostream>
#include<vector>
#include<queue>
#include<iomanip>
using namespace std;
void redln(vector<vector<int > >*retailers,int N)
{ 
  for(int i=0;i<N;i++)
  {
    int m=0;
    cin>>m;
    (*retailers)[i].resize(m);
    for(int j=0;j<m;j++)
    {
      int t;
      cin>>t;
      (*retailers)[i][j]=t; 
    }
  }
}
void bfs_(vector<vector<int > >*retailers,double root_price,double r,double *min,int*num)
{
   queue<int >qt;
   if(0==(*retailers)[0].size())
   {
     (*min)=root_price;
       (*num)=1;
   }else
   qt.push(0);
   while(!qt.empty())
   { 
     int len=qt.size();
     root_price*=(1+r/100); 
     for(int i=0;i<len;i++)
     {  
          for(int add=0;add<(*retailers)[qt.front()].size();add++)
        {
          int tid=(*retailers)[qt.front()][add];
                  if(0==(*retailers)[tid].size())
          { 
                if(0==(*num)||(*min)>root_price)
            { 
                 (*min)=root_price;
                          (*num)=1;
            } 
                 else if((*num)>0&&(*min)==root_price)
                (*num)++; 
          }
          else
          qt.push(tid);
        } 
       qt.pop();
     }
   }
}
int main()
{
  int N;
  double root_price,r;
  cin>>N>>root_price>>r;
  vector<vector<int > >retailers;
  retailers.resize(N);
  redln(&retailers,N); 
  double min=root_price;
  int num=0;
  bfs_(&retailers,root_price,r,&min,&num);
  cout<<setiosflags(ios::fixed)<<setprecision(4)<<min<<" "<<num<<endl;  
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值