杭电1021 Fibonacci Again

Fibonacci Again




Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).


Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.


Sample Input

  
  
0 1 2 3 4 5

Sample Output
  
  
no no yes no no no

题解
刚看到这个题时,没有思路,如果直接求肯定是不对的,因为F(n)太大了。后来想了一下除以3的事情,3的余数只有0.,1,2, 由于F(n) = F(n-1) + F(n-2) ,
所以这道题实际上是3的余数的相加再对3取余的问题。在对前几项取余就会发现其中的规律,知道这个规律,代码就只有几行。
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		int a[]= {1,2,0,2,2,1,0,1};
		int n;
		while(in.hasNext()){
			n=in.nextInt();
			if(a[n%8]==0){
				System.out.println("yes");
			}else{
				System.out.println("no");
			}
		}
		
	}

}










  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值