杭电OJ Fibonacci Again

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51636    Accepted Submission(s): 24430


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
 

Author
Leojay
//代码一 不够简便 运行时间过长
# include <stdio.h>

int HanShu(int N)
{
    if (N == 0)
        return 7;
    else if (N == 1)
        return 11;
    else
        return HanShu(N-1)+HanShu(N-2);
}

int main (void)
{
    int N;
    int iNum;
    while (scanf("%d", &N)!=EOF)
    {
        if (N == 0 || N == 1)
        {
            printf ("no\n");
            continue;
        }
        iNum = HanShu(N);
        if (iNum%3 == 0)
        {
            printf ("yes\n");
        }
        else
        {
            printf ("no\n");
        }
    }
    return 0;
}

//代码2
# include <stdio.h>
# include <stdlib.h>


int main (void)
{
    int N;
    while (scanf ("%d", &N) != EOF)
    {
        if (N < 2 || (N-2)%4 != 0)
        {
            printf ("no\n");
        }
        else
        {
            printf ("yes\n");
        }
    }

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值