Fibonacci Again
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 51636 Accepted Submission(s): 24430
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
Print the word "no" if not.
Sample Input
0 1 2 3 4 5
Sample Output
no no yes no no no
Author
Leojay
//代码一 不够简便 运行时间过长
# include <stdio.h>
int HanShu(int N)
{
if (N == 0)
return 7;
else if (N == 1)
return 11;
else
return HanShu(N-1)+HanShu(N-2);
}
int main (void)
{
int N;
int iNum;
while (scanf("%d", &N)!=EOF)
{
if (N == 0 || N == 1)
{
printf ("no\n");
continue;
}
iNum = HanShu(N);
if (iNum%3 == 0)
{
printf ("yes\n");
}
else
{
printf ("no\n");
}
}
return 0;
}
//代码2
# include <stdio.h>
# include <stdlib.h>
int main (void)
{
int N;
while (scanf ("%d", &N) != EOF)
{
if (N < 2 || (N-2)%4 != 0)
{
printf ("no\n");
}
else
{
printf ("yes\n");
}
}
return 0;
}