1028. List Sorting (25)



Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
 
分析:
(1)快排解决
(2)注意最后一个case直接string比较会超过时间,原因大致是因为用了iostream.
    那么入股用cstring 的话,就要考虑用strcmp(A,B), a<b则返回一个小于0的数,相等返回0,大于返回大于0的数, 万一需要可以使用
(一个测试点还算是业界良心)
 
#include <iostream>
#include <string>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <cstring>
using namespace std;

struct student {
	int id;
	char name[20];
	int score;
};

bool cmp1 (student p,student q){
	return p.id<q.id;
}
bool cmp2(student p,student q){
	if (strcmp(p.name,q.name)!=0) return strcmp(p.name,q.name)<0;
	else return p.id<q.id;
}
bool cmp3(student p,student q){
	if (p.score!=q.score) return p.score<q.score;
	else return p.id<q.id;
}
int main (){
	int n,c,i;
	scanf("%d%d",&n,&c);
	vector<student> rd(n);
	for (i=0;i<n;i++){
		scanf("%d%s%d",&rd[i].id,&rd[i].name,&rd[i].score);
	}
	if (c==1){ sort (rd.begin(),rd.end(),cmp1);
	}
	else if (c==2){sort (rd.begin(),rd.end(),cmp2);
	}
	else if (c==3){sort (rd.begin(),rd.end(),cmp3);
	}

	for (i=0;i<n;i++){
		printf("%06d %s %d\n",rd[i].id,rd[i].name,rd[i].score);
	}
	//cout<<"1";
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值