Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.
Input Specification:
Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
Output Specification:
For each test case, print S1 - S2 in one line.
Sample Input:They are students. aeiouSample Output:
Thy r stdnts.
分析:
(1)题目已经暗示了可能会超时,我还是傻傻的写了一遍套用循环,结果2个测试点不过。那么,应该用hash和数组来记录,从而达到不嵌套循环的目的。
(2)利用hash数组降低时间复杂度的方法要 mark mark mark。
#include <iostream>
#include <string>
using namespace std;
int main (){
string a,b;
getline (cin,a);
getline (cin,b);
int i;
int hs[10002]={0};
for (i=0;i<b.length();i++){
hs[b[i]]=1;
}
for (i=0;i<a.length();i++){
if (hs[a[i]]==0){
cout<<a[i];
}
}
return 0;
}