1050. String Subtraction (20)

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.

分析:

(1)题目已经暗示了可能会超时,我还是傻傻的写了一遍套用循环,结果2个测试点不过。那么,应该用hash和数组来记录,从而达到不嵌套循环的目的。

(2)利用hash数组降低时间复杂度的方法要 mark mark mark。

#include <iostream>
#include <string>
using namespace std;
int main (){
	string a,b;
	getline (cin,a);
	getline (cin,b);
	int i;
	int hs[10002]={0};
	for (i=0;i<b.length();i++){
		hs[b[i]]=1;
	}
	for (i=0;i<a.length();i++){
		if (hs[a[i]]==0){
			cout<<a[i];
		}
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值