杭电 4004 The Frog's Games

The Frog's Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s):     Accepted Submission(s):


Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output
For each case, output a integer standing for the frog's ability at least they should have.
 

Sample Input
  
  
6 1 2 2 25 3 3 11 2 18
 

Sample Output
  
  
4 11


题目大意:l表示河的宽度,n表示河中能站石头的个数,m表示青蛙能跳的最多次数,下面跟n组数据,分别表示石头距离开始的位置,求青蛙至少一次跳多远,才能在m次及以内到对岸!


代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int a[500005];
int main()
{
    int l,ll,n,m,max,sum;
    int i,j,cont,t;
    while(~scanf("%d%d%d",&l,&n,&m))
    {
        max=0;sum=0;
        memset(a,0,sizeof(a));
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n+1);//对石头从近到远排序
            for(i=1;i<=n;i++)
        {
            if(a[i]-a[i-1]>max)
                max=a[i]-a[i-1];//找出石头间的最大间距
        }
        if(l-a[n]>max)
            max=l-a[n];//对岸和最后一个石头也要算

        for(j=max;j<=l;j++)//枚举青蛙能跳的距离,进行验证
        {

            i=1;cont=1;t=0;ll=l;
            while(l>0&&i<=n)
            {
                ll-=a[i]-a[i-1];
                if(a[i]-t>j)
                {cont++;t=a[i-1];}
                if(i==n)
                {
                    if(l-t>j)
                        {cont++;t=a[i-1];}
                }
                i++;
            }
            if(cont<=m)
                break;//遇到合适的跳出循环输出
        }
        printf("%d\n",j);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值