POJ 2955 Brackets

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions:  Accepted: 

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

代码中详解!!!


AC代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

int dp[105][105];
char str[1005];

int main()
{
    int i,j,o,t;
    while(cin>>str,str[0]!='e')
    {
        int l=strlen (str);
        for(i=0;i<l;i++)
            for(j=0;j<l;j++)
            dp[i][j]=0;//初始化状态
        for(o=2;o<=l;o++)//枚举所有区间长度
        {
            for(i=0;i<l-o+1;i++)
            {
                j=i+o-1;//控制[i,j]区间长度为o。
                for(t=i;t<j;t++)//检索[i,j]中的满足条件的子区间
                {
                    dp[i][j]=max(dp[i][j],dp[i][t]+dp[t+1][j]);//更新子区间合成的区间最大值MAXXX
                    if((str[i]=='('&&str[j]==')')||(str[i]=='['&&str[j]==']'))
                        dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);//比较MAXXX与整体区间的相比谁大
                }
            }
        }
        cout<<dp[0][l-1]<<endl;
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值