poj 2955 Brackets

Description

We give the following inductive definition of a “regular brackets” sequence:
the empty sequence is a regular brackets sequence,if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, andif a and b are regular brackets sequences, then ab is a regular brackets sequence.no other sequence is a regular brackets sequence,For instance, all of the following character sequences are regular brackets sequences:
(), [], (()), ()[], ()[()]
while the following character sequences are not:
(, ], )(, ([)], ([(]
Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.
Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

题目大意,找到有多少匹配的括号序列。
看到括号匹配就想着拿栈做,最后才发现栈根本处理不了,因为序列里的括号不会都完全匹配。
于是就发现可以dp,然后又发现简直就是区间dp模板题…找个模板改了改就过了。
大概意思是dp[l][r]表示 l 到 r的答案,如果s[l] 与 s[r]匹配,则dp[l][r] = max(dp[l][r] , dp[l+1][r-1] + 2), 其次dp[l][r] 会被 dp[l][k] 和 dp[k+1][r] 更新。
代码如下
i , j , k 分别是区间长度,区间左端点,区间内点

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int sz = 201;
int dp[sz][sz];
char ins[sz];
int main ()
{
    while(scanf("%s", ins + 1) != EOF)
    {
        memset(dp,0,sizeof(dp));
        if(ins[1] == 'e')
            break;
        int len = strlen(ins + 1);
        for(int i = 1; i <= len; i ++)
            for(int j = 1; j <= len - i + 1 ; j ++)
            {
                int k = j + i - 1;
                if((ins[j] == '(' && ins[k] == ')') || (ins[j] == '[' && ins[k] == ']'))
                    dp[j][k] = dp[j+1][k-1] + 2;
                for(int l = j ; l < k ; l ++)
                    dp[j][k] = max(dp[j][k], dp[j][l] + dp[l+1][k]);
            }
        printf("%d\n", dp[1][len]);
    }
    return 0;
}
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值