杭电acm 2616

Kill the monster

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 818    Accepted Submission(s): 588


Problem Description
There is a mountain near yifenfei’s hometown. On the mountain lived a big monster. As a hero in hometown, yifenfei wants to kill it.
Now we know yifenfei have n spells, and the monster have m HP, when HP <= 0 meaning monster be killed. Yifenfei’s spells have different effect if used in different time. now tell you each spells’s effects , expressed (A ,M). A show the spell can cost A HP to monster in the common time. M show that when the monster’s HP <= M, using this spell can get double effect.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m (2<n<10, 1<m<10^7), express how many spells yifenfei has.
Next n line , each line express one spell. (Ai, Mi).(0<Ai,Mi<=m).
 

Output
For each test case output one integer that how many spells yifenfei should use at least. If yifenfei can not kill the monster output -1.
 

Sample Input
  
  
3 100 10 20 45 89 5 40 3 100 10 20 45 90 5 40 3 100 10 20 45 84 5 40
 

Sample Output
  
  
3 2 -1
#include<stdio.h>
#include<string.h>
int n,a[11],b[11],c[11],min;
void dfs(int cur,int hp)
{
    int i;
    if(hp<=0)
        if(cur<min)
            min=cur;
    if(cur>n)
        ;
    for(i=0;i<n;i++)
    {
        if(!c[i])
        {
            if(hp>b[i])
            {
                c[i]=1;
                dfs(cur+1,hp-a[i]);
                c[i]=0;
            }
            else
            {
                c[i]=1;
                dfs(cur+1,hp-2*a[i]);
                c[i]=0;
            }

        }
    }
}
int main()
{

    int i,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(c,0,sizeof(c));
        for(i=0;i<n;i++)
            scanf("%d%d",&a[i],&b[i]);
            min=11;
        dfs(0,m);
        if(min!=11)
        printf("%d\n",min);
        else
            printf("-1\n");
    }
return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值