Kill the monster(深搜)

Problem Description
There is a mountain near yifenfei’s hometown. On the mountain lived a big monster. As a hero in hometown, yifenfei wants to kill it. 
Now we know yifenfei have n spells, and the monster have m HP, when HP <= 0 meaning monster be killed. Yifenfei’s spells have different effect if used in different time. now tell you each spells’s effects , expressed (A ,M). A show the spell can cost A HP to monster in the common time. M show that when the monster’s HP <= M, using this spell can get double effect.
 
Input
The input contains multiple test cases.
Each test case include, first two integers n, m (2<n<10, 1<m<10^7), express how many spells yifenfei has.
Next n line , each line express one spell. (Ai, Mi).(0<Ai,Mi<=m).
 
Output
For each test case output one integer that how many spells yifenfei should use at least. If yifenfei can not kill the monster output -1.
 
Sample Input
3 100
10 20
45 89
5  40

3 100
10 20
45 90
5 40

3 100
10 20
45 84
5 40
 
Sample Output
3
2
-1
 
Author
yifenfei
 
Source
奋斗的年代
 
Recommend
yifenfei

题意:

山上有个大boss,让你去击杀,boss有m多的血,而你有n种技能,当每种技能在使用时boss的血量低于某个值时,伤害翻倍!问你使用的最小技能数是多少!

思路:

深搜,搜出每种情况,然后比较,得出最小的那个!

代码:

#include <bits/stdc++.h>
using namespace std;
int n,m;
struct node
{
	int x;
	int y;
}a[11];
bool vis[11];
int sum;
void dfs(int aa,int b)
{
    int i,j; 
	if(b>=sum)     //剪枝,要学会
	return;
	if(aa<=0)
	{
		if(sum>b)
		sum=b;
		return;
	}
	for (i=0;i<n;i++)
	{
		if(!vis[i])
		{
			vis[i]=1;
			if(aa<=a[i].y)
			dfs(aa-2*a[i].x,b+1);
		    else
		   	dfs(aa-a[i].x,b+1);
		    vis[i]=0;
		}
	}
	
}
int main()
{
	int i,j;
	while(cin>>n>>m)
	{
		
		for(i=0;i<n;i++)
		cin>>a[i].x>>a[i].y;
		memset(vis,0,sizeof(vis));
		sum=11;
		dfs(m,0);
		if(sum==11)
		cout<<"-1"<<endl;
		else
		cout<<sum<<endl; 
		
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值