HDU 1829 A Bug's Life(种类并查集)

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1829


A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.

最近因为要给14级的新生讲数据结构,所以回头整理了一下并查集专题,重新做了一下种类并查集,然后挑了这道做个笔记。


这个题就是并查集的经典用法之:找同性恋。

题意非常简单:A喜欢B  B喜欢C  如此这般  然后去找这个关系网里面是否存在同性恋的BUG。(ps:在如今同性恋已经全美合法的情况下,这个题才是个BUG)


那么其实有2种思路,一种是维护一个并查集,然后去根据每个点到根节点的距离去添加点和判断性别,但是这样比较麻烦。

所以我采用了后一种比较容易理解的:维护2个并查集,与A性别相同的和与A性别不同的。对于每一条A喜欢B,就把B加到A的异性集合里面,然后把A加到B的异性集合里面。然后如果AB在同一个集合的话,BUG就产生了。


下面贴代码。

#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <map>
#include <vector>
#include <iostream>
#include <algorithm>
#define moo 1000000007//10^9+7
#define PI acos(-1.0)
using namespace std;

int root[1000000+10];
int sex[1000000+10];//性别标记,sex[x]表示x的异性集合中的其中一个
int fi(int x)
{
    while(x!=root[x])
        x=root[x];
    return x;
}//并查集基础操作之找根
void uni(int x,int y)
{
    int t1=fi(x);
    int t2=fi(y);
    if(t1!=t2)
        root[t2]=t1;
}//并查集基础操作之合并
int main()
{
    int T;
    cin>>T;
    int dd=T;
    while(T--)
    {
        printf("Scenario #%d:\n",dd-T);


        int n,m;
        scanf("%d%d",&n,&m);
        memset(sex,0,sizeof(sex));//异性集合初始化,0代表暂时没有发现异性

        for(int i=1;i<=n;i++)
            root[i]=i;

        int x,y,flag=0;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            if(flag==1)
                continue;
            if(fi(x)==fi(y))
            {
                flag=1;
                continue;
            }//x,y本来就在一个集合,说明他们已经确定同性,说明找出了bug
            if(sex[x]!=0)
                uni(sex[x],y);//合并他们的异性集合
            if(sex[y]!=0)
                uni(sex[y],x);
            sex[x]=y;
            sex[y]=x;
        }
        if(flag==0)
            printf("No suspicious bugs found!\n\n");
        else
            printf("Suspicious bugs found!\n\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值