Japan
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 19689 | Accepted: 5331 |
Description
Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.
Input
The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.
Output
For each test case write one line on the standard output:
Test case (case number): (number of crossings)
Test case (case number): (number of crossings)
Sample Input
1 3 4 4 1 4 2 3 3 2 3 1
Sample Output
Test case 1: 5
题意:每次给你n组数,问你这些连线有多少交叉的点。
思路:排序后用树状数组。二元素排序的时候让第一元素从小到大排,第二元素从大到小排,排完后自己画一下就明白了。
AC代码如下:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int a[10100];
struct node
{ int x,y;
} city[1000005];
bool cmp(node a,node b)
{ if(a.x>b.x)
return true;
else if(a.x==b.x)
return a.y>b.y;
else
return false;
}
int lowbit(int x)
{ return x&(-x);
}
void update(int x)
{ while(x<=1000)
{ a[x]++;
x+=lowbit(x);
}
}
int sum(int x)
{ int ret=0;
while(x)
{ ret+=a[x];
x-=lowbit(x);
}
return ret;
}
int main()
{ int t,T,n,m,k,i,j;
long long ret;
scanf("%d",&T);
for(t=1;t<=T;t++)
{ scanf("%d%d%d",&n,&m,&k);
for(j=1;j<=k;j++)
scanf("%d%d",&city[j].x,&city[j].y);
ret=0;
sort(city+1,city+1+k,cmp);
memset(a,0,sizeof(a));
for(j=1;j<=k;j++)
{ ret+=sum(city[j].y-1);
update(city[j].y);
}
printf("Test case %d: %lld\n",t,ret);
}
}