POJ 3067(树状数组)

题目:

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output:
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

题意:

两边分别有n,m个点,每边点的编号从上到下位1,2,3。。。

现在有K条边连接两边的点,最多只有两条边相交于一点而不会出现三条边以上交于一点的状况,问一共有几个交点

 

思路:这是一个逆序对数的一个应用。灵活处理

相交的情况必然是在Li<Lj的情况下,Ri>Rj

所以在对L,R排序之后,只需要看R里面逆序数的多少即可。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<stack>
#include<queue>
#include<vector>
#define ll long long
using namespace std;
ll t;
ll n,m,k;
struct node{
	ll from;
	ll to;
}a[1000005];
bool cmp(node p1,node p2)
{
	if(p1.from ==p2.from ){
		return p1.to <p2.to ;
	}
	else{
	    return p1.from <p2.from ; 
	} 
}
ll c[1005],b[1005];
ll lowbit(ll x)
{
	return x&(-x);
}
void update(ll x)
{
	while(x<=m)
	{
		c[x]++;
		x=x+lowbit(x);
	}
}
ll getsum(ll x)
{
	ll ans=0;
	while(x>0)
	{
		ans=ans+c[x];
	    x=x-lowbit(x);
	} 
	return ans;
}
int main()
{
	cin>>t;
	ll s=0;
	while(t--)
	{
		s++;
		scanf("%lld%lld%lld",&n,&m,&k);
		ll i,j,val,l,d,f;
		ll sum=0;
		for(i=1;i<=k;i++)
		{
			scanf("%lld%lld",&a[i].from ,&a[i].to );
		}
		sort(a+1,a+1+k,cmp);
		memset(c,0,sizeof(c));
		for(i=1;i<=k;i++)
		{
			update(a[i].to );
			sum=sum+getsum(m)-getsum(a[i].to );//getsum(m)代表已读入的数的个数。
			//getsum(a[i].to)代表小于等于次数的个数,相减即大于此数的数的个数。 
		}
		printf("Test case %lld: %lld\n",s,sum);
	}
	return 0;
}

 

注意:若是在Li>Lj的情况下,Ri<Rj的情况下也相交,但是这样写代码需要考虑一些东西。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<vector>
#define ll long long
using namespace std;
ll t;
ll n,m,k;
struct node{
	ll from;
	ll to;
}a[1000005];
bool cmp(node p1,node p2)
{
	if(p1.from ==p2.from ){
		return p1.to >p2.to ;
	}
	else{
	    return p1.from >p2.from ; 
	} 
}
ll c[1005],b[1005];
ll lowbit(ll x)
{
	return x&(-x);
}
void update(ll x)
{
	while(x<=m)
	{
		c[x]++;
		x=x+lowbit(x);
	}
}
ll getsum(ll x)
{
	ll ans=0;
	while(x>0)
	{
		ans=ans+c[x];
	    x=x-lowbit(x);
	} 
	return ans;
}
int main()
{
	cin>>t;
	ll s=0;
	while(t--)
	{
		s++;
		scanf("%lld%lld%lld",&n,&m,&k);
		ll i,j,val,l,d,f;
		ll sum=0;
		for(i=1;i<=k;i++)
		{
			scanf("%lld%lld",&a[i].from ,&a[i].to );
		}
		sort(a+1,a+1+k,cmp);
		memset(c,0,sizeof(c));
		memset(b,0,sizeof(b));
		for(i=1;i<=k;i++)//注意终点相同时,两条线无交点 
		{
			j=getsum(a[i].to );
			update(a[i].to );
			j=j-b[a[i].to ];
			b[a[i].to ]++;
			sum=sum+j;
		}
		printf("Test case %lld: %lld\n",s,sum);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值