Counterfeit Dollar
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 38982 | Accepted: 12428 |
Description
Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.
Input
The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.
Output
For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.
Sample Input
1 ABCD EFGH even ABCI EFJK up ABIJ EFGH even
Sample Output
K is the counterfeit coin and it is light.
题意:找到重量不同的假币,并求出它比真的重还是轻。
思路:用k表示它的可疑度,每次重量不同时k++,同时记录轻的那边num[i]++,重的那边num[i]--。
AC代码如下:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int num1[20],num2[20];
char s1[10],s2[10],s3[10],c;
int main()
{ int t,i,j,k;
scanf("%d",&t);
while(t--)
{ memset(num1,0,sizeof(num1));
memset(num2,0,sizeof(num2));
k=0;
for(i=1;i<=3;i++)
{ scanf("%s%s%s",s1,s2,s3);
if(s3[0]=='e')
{ for(j=0;j<=strlen(s1)-1;j++)
num1[s1[j]-'A']=1;
for(j=0;j<=strlen(s2)-1;j++)
num1[s2[j]-'A']=1;
}
else if(s3[0]=='u')
{ k++;
for(j=0;j<=strlen(s1)-1;j++)
num2[s1[j]-'A']++;
for(j=0;j<=strlen(s2)-1;j++)
num2[s2[j]-'A']--;
}
else if(s3[0]=='d')
{ k++;
for(j=0;j<=strlen(s1)-1;j++)
num2[s1[j]-'A']--;
for(j=0;j<=strlen(s2)-1;j++)
num2[s2[j]-'A']++;
}
}
for(i=0;i<=11;i++)
if(num1[i]==0 && num2[i]+k==0)
{ c='A'+i;
printf("%c is the counterfeit coin and it is light.\n",c);
}
else if(num1[i]==0 && num2[i]-k==0)
{ c='A'+i;
printf("%c is the counterfeit coin and it is heavy.\n",c);
}
}
}
附上POJ上大神们写的测试数据:
sample input
12
ABCD EFGH even
ABCI EFJK up
ABIJ EFGH even
AGHL BDEC even
JKI ADE up
J K even
ABCDEF GHIJKL up
ABC DEF even
I J down
ABCDEF GHIJKL up
ABHLEF GDIJKC down
CD HA even
A B up
B A down
A C even
A B up
B C even
DEFG HIJL even
ABC DEJ down
ACH IEF down
AHK IDJ down
ABCD EFGH even
AB IJ even
A L down
EFA BGH down
EFC GHD even
BA EF down
A B up
A C up
L K even
ACEGIK BDFHJL up
ACEGIL BDFHJK down
ACEGLK BDFHJI down
ACEGIK BDFHJL up
ACEGIL BDFHJK down
ACEGLK BDFHJI up
sample output
K is the counterfeit coin and it is light.
I is the counterfeit coin and it is heavy.
I is the counterfeit coin and it is light.
L is the counterfeit coin and it is light.
B is the counterfeit coin and it is light.
A is the counterfeit coin and it is heavy.
A is the counterfeit coin and it is light.
L is the counterfeit coin and it is heavy.
A is the counterfeit coin and it is light.
A is the counterfeit coin and it is heavy.
L is the counterfeit coin and it is light.
K is the counterfeit coin and it is heavy.