Partitioning by Palindromes - UVa 11583 dp

Partitioning by Palindromes

Can you read upside-down?

We say a sequence of characters is a palindrome if it is the same written forwards and backwards. For example, 'racecar' is a palindrome, but 'fastcar' is not.

partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, ('race', 'car') is a partition of 'racecar' into two groups.

Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?

For example:

  • 'racecar' is already a palindrome, therefore it can be partitioned into one group.
  • 'fastcar' does not contain any non-trivial palindromes, so it must be partitioned as ('f', 'a', 's', 't', 'c', 'a', 'r').
  • 'aaadbccb' can be partitioned as ('aaa', 'd', 'bccb').

Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.

Sample Input

3
racecar
fastcar
aaadbccb

Sample Output

1
7
3


题意:给你一个字符串,问这个字符少最少可以分解成多少个回文串。

思路:dp,先求出那些是回文串,然后每次dp[0][j]遍历其中的分离点。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[1010];
int dp[1010][1010];
int main()
{ int n,i,j,k,len;
  scanf("%d",&n);
  while(n--)
  { scanf("%s",s);
    memset(dp,0,sizeof(dp));
    len=strlen(s);
    for(i=0;i<len;i++)
    { dp[i][i]=1;
      dp[i+1][i]=1;
    }
    for(i=len-1;i>=0;i--)
     for(j=i+1;j<len;j++)
     { dp[i][j]=min(dp[i][j-1]+1,dp[i+1][j]+1);
       if(s[i]==s[j] && dp[i+1][j-1]==1)
        dp[i][j]=min(dp[i][j],1);
     }
    for(j=0;j<len;j++)
     for(k=0;k<=j;k++)
      dp[0][j]=min(dp[0][j],dp[0][k-1]+dp[k][j]);
    printf("%d\n",dp[0][len-1]);
  }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值