Dividing
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 58535 | Accepted: 15069 |
Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input
Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000.
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.
Output
For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.".
Output a blank line after each test case.
Output a blank line after each test case.
Sample Input
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
Sample Output
Collection #1: Can't be divided. Collection #2: Can be divided.
题意:有价值为1-6的石头各多少个,问你能不能分成两堆使得价值和相同。
思路:当对每个石头做背包使得dp[sum/2]=sum/2时,可以分。另外将每堆石头看成1、2、4、8、16等等,减少复杂度,因为他们可以组成任意数量的石头。
AC代码如下:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int num[10],sum,dp[120010];
int main()
{ int n,m,i,j,k,t=0;
while(true)
{ memset(dp,0,sizeof(dp));
sum=0;
for(i=1;i<=6;i++)
{ scanf("%d",&num[i]);
sum+=num[i]*i;
}
if(sum==0)
break;
if(t)
printf("\n");
printf("Collection #%d:\n",++t);
if(sum&1)
{ printf("Can't be divided.\n");
continue;
}
sum/=2;
for(i=1;i<=6;i++)
{ k=1;
while(num[i]>=k)
{ m=i*k;
for(j=sum;j>=m;j--)
dp[j]=max(dp[j],dp[j-m]+m);
num[i]-=k;
k<<=1;
}
if(num[i])
{ m=i*num[i];
for(j=sum;j>=m;j--)
dp[j]=max(dp[j],dp[j-m]+m);
}
}
if(dp[sum]==sum)
printf("Can be divided.\n");
else
printf("Can't be divided.\n");
}
}